add eabi autoselection for the kernel as well - fixes iptables problems
authorFelix Fietkau <nbd@openwrt.org>
Thu, 14 Feb 2008 22:01:15 +0000 (22:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 14 Feb 2008 22:01:15 +0000 (22:01 +0000)
SVN-Revision: 10461

target/linux/ixp4xx/Makefile
target/linux/ixp4xx/config-default

index ec931a0a991a02833262b34534ff75776943ea95..eec8d13f724aa69ebdef4183d5c222000ac7da00 100644 (file)
@@ -16,6 +16,12 @@ LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
 DEFAULT_PACKAGES += ixp4xx-microcode
 
 $(eval $(call BuildTarget))
index 5116bd82b648af1e5f74d1e68fb6d60cbc0605c0..5b76e9c54d098e351d81f307a53b6408d982f082 100644 (file)
@@ -1,5 +1,5 @@
 # CONFIG_8139TOO is not set
-CONFIG_AEABI=y
+# CONFIG_AEABI is not set
 CONFIG_ALIGNMENT_TRAP=y
 # CONFIG_APM is not set
 # CONFIG_ARCH_AAEC2000 is not set
@@ -298,7 +298,7 @@ CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED=y
 # CONFIG_NO_IDLE_HZ is not set
 # CONFIG_NTFS_FS is not set
 # CONFIG_NVRAM is not set
-CONFIG_OABI_COMPAT=y
+# CONFIG_OABI_COMPAT is not set
 # CONFIG_PATA_ALI is not set
 # CONFIG_PATA_AMD is not set
 CONFIG_PATA_ARTOP=m