kernel: bump 4.9 to 4.9.198
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 30 Oct 2019 11:55:28 +0000 (12:55 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 31 Oct 2019 08:18:43 +0000 (09:18 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm47xx/patches-4.9/159-cpu_fixes.patch

index 2b58a8205d37ee290a25185d23ee612d393ad4f0..01504f583ea31becb292aec4b288945d742a0ee2 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .197
+LINUX_VERSION-4.9 = .198
 LINUX_VERSION-4.14 = .150
 
-LINUX_KERNEL_HASH-4.9.197 = 553568b6728d505da70efa8247a66ad158e849c8f5f40d715612ef4e9ed14a0c
+LINUX_KERNEL_HASH-4.9.198 = 9572ebfa6ba0efcf9f1ec7b62c7b89baa36a621ab9fd4c5ad025196c549605ac
 LINUX_KERNEL_HASH-4.14.150 = 65c5a4b86b858ba58642f46ae8c983990376d1946e59cc7e054e85b1b7eb57b0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index ceea07d8c120d137292830b171c9b647b2568444..681e1d61c5e8064cc06a34abbba58541a01183d6 100644 (file)
        /*
 --- a/arch/mips/mm/tlbex.c
 +++ b/arch/mips/mm/tlbex.c
-@@ -973,6 +973,9 @@ build_get_pgde32(u32 **p, unsigned int t
+@@ -980,6 +980,9 @@ build_get_pgde32(u32 **p, unsigned int t
                uasm_i_srl(p, ptr, ptr, SMP_CPUID_PTRSHIFT);
                uasm_i_addu(p, ptr, tmp, ptr);
  #else
                UASM_i_LA_mostly(p, ptr, pgdc);
  #endif
                uasm_i_mfc0(p, tmp, C0_BADVADDR); /* get faulting address */
-@@ -1316,6 +1319,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1323,6 +1326,9 @@ static void build_r4000_tlb_refill_handl
  #ifdef CONFIG_64BIT
                build_get_pmde64(&p, &l, &r, K0, K1); /* get pmd in K1 */
  #else
                build_get_pgde32(&p, K0, K1); /* get pgd in K1 */
  #endif
  
-@@ -1327,6 +1333,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1334,6 +1340,9 @@ static void build_r4000_tlb_refill_handl
                build_update_entries(&p, K0, K1);
                build_tlb_write_entry(&p, &l, &r, tlb_random);
                uasm_l_leave(&l, p);
                uasm_i_eret(&p); /* return from trap */
        }
  #ifdef CONFIG_MIPS_HUGE_TLB_SUPPORT
-@@ -2014,6 +2023,9 @@ build_r4000_tlbchange_handler_head(u32 *
+@@ -2021,6 +2030,9 @@ build_r4000_tlbchange_handler_head(u32 *
  #ifdef CONFIG_64BIT
        build_get_pmde64(p, l, r, wr.r1, wr.r2); /* get pmd in ptr */
  #else
        build_get_pgde32(p, wr.r1, wr.r2); /* get pgd in ptr */
  #endif
  
-@@ -2060,6 +2072,9 @@ build_r4000_tlbchange_handler_tail(u32 *
+@@ -2067,6 +2079,9 @@ build_r4000_tlbchange_handler_tail(u32 *
        build_tlb_write_entry(p, l, r, tlb_indexed);
        uasm_l_leave(l, *p);
        build_restore_work_registers(p);