scripts: fix build warning when overriding packages
authorZefir Kurtisi <zefir.kurtisi@neratec.com>
Wed, 12 Oct 2016 15:50:56 +0000 (17:50 +0200)
committerJohn Crispin <john@phrozen.org>
Sat, 15 Oct 2016 09:36:51 +0000 (11:36 +0200)
If core packages are overridden, CONFIG_OVERRIDE_PKGS is set
based on the scan order of packages, which eventually causes
that config value to be modified on each build and with
that causes the build process to warn for configuration
being out of sync.

This commit changes the CONFIG_OVERRIDE_PKGS to be sorted
and prevents that false warning.

Signed-off-by: Zefir Kurtisi <zefir.kurtisi@neratec.com>
scripts/package-metadata.pl

index 09aed96..f5d28e4 100755 (executable)
@@ -351,7 +351,7 @@ sub print_package_overrides() {
        keys %overrides > 0 or return;
        print "\tconfig OVERRIDE_PKGS\n";
        print "\t\tstring\n";
-       print "\t\tdefault \"".join(" ", keys %overrides)."\"\n\n";
+       print "\t\tdefault \"".join(" ", sort keys %overrides)."\"\n\n";
 }
 
 sub gen_package_config() {