this patch fixes toolchain parallel build, which reduces build time.
authorTravis Kemen <thepeople@openwrt.org>
Fri, 5 Mar 2010 20:15:12 +0000 (20:15 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Fri, 5 Mar 2010 20:15:12 +0000 (20:15 +0000)
In order to enable parallel build, change line 21 of
include/host-build.mk from:

override MAKEFLAGS=

to:

override MAKEFLAGS=$(MAKE_JOBS)

-Raphael

SVN-Revision: 19995

include/host-build.mk
toolchain/gcc/Makefile

index 6324276a70453fa065e82c43f179e25d3686b689..75792579eb04f8cfcff430e0b30ea7dd580da107 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -80,7 +80,7 @@ define Host/Compile
 endef
 
 define Host/Install/Default
-       $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
 endef
 
 define Host/Install
index 8b920607e021343cbd93dbbf324353d294a8b635..9c820f2feca59a81cfec96957c58a7ce9af7ca39 100644 (file)
@@ -250,7 +250,7 @@ define SetupExtraArch
 endef
 
 define Stage2/Install
-       $(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
+       $(_SINGLE)$(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(TOOLCHAIN_DIR)/usr; \