kernel: bump 5.4 to 5.4.134
authorJohn Audia <graysky@archlinux.us>
Tue, 20 Jul 2021 16:23:02 +0000 (12:23 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 25 Jul 2021 11:52:38 +0000 (13:52 +0200)
All patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0040-fbdev-add-FBIOCOPYAREA-ioctl.patch
target/linux/generic/config-5.4
target/linux/layerscape/patches-5.4/819-uart-0001-tty-serial-lpuart-add-power-domain-support.patch
target/linux/layerscape/patches-5.4/819-uart-0004-MLK-18137-fsl_lpuart-Fix-loopback-mode.patch
target/linux/layerscape/patches-5.4/819-uart-0005-tty-serial-fsl_lpuart-enable-dma-mode-for-imx8qxp.patch
target/linux/layerscape/patches-5.4/819-uart-0008-MLK-21445-serial-fsl_lpuart-do-HW-reset-for-communic.patch
target/linux/layerscape/patches-5.4/819-uart-0009-MLK-17133-02-tty-serial-lpuart-add-runtime-pm-suppor.patch
target/linux/layerscape/patches-5.4/819-uart-0010-tty-serial-lpuart-enable-wakeup-source-for-lpuart.patch
target/linux/layerscape/patches-5.4/819-uart-0013-LF-484-tty-serial-lpuart-support-UPIO_MEM32-for-lpua.patch

index 6dc4ad61332f34661a4ea8aaa055594be6449f70..0ab7ce31cedf2ad87b7861f9e5d9100ef099420f 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .133
+LINUX_VERSION-5.4 = .134
 LINUX_VERSION-5.10 = .52
 
-LINUX_KERNEL_HASH-5.4.133 = 89a366fbb8784f5bc296c9f3311094e9e4cffeb6dbdf7589168cc032cb950830
+LINUX_KERNEL_HASH-5.4.134 = c9fb861642161c256e10c97c35ccce18831e688d87ead53c18e3226778e05841
 LINUX_KERNEL_HASH-5.10.52 = 769e57a0fa218589fa2f8460b8682eb784a72718c7a3d95295f382a77902ae79
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 8fa4ddf5c89926154fc8f7742ecb4f456b13f717..f42c2697f34301e4e5960df043ba64867a13cb43 100644 (file)
@@ -234,7 +234,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static int bcm2708_fb_register(struct bcm2708_fb *fb)
 --- a/drivers/video/fbdev/core/fbmem.c
 +++ b/drivers/video/fbdev/core/fbmem.c
-@@ -1076,6 +1076,30 @@ fb_blank(struct fb_info *info, int blank
+@@ -1074,6 +1074,30 @@ fb_blank(struct fb_info *info, int blank
  }
  EXPORT_SYMBOL(fb_blank);
  
@@ -265,7 +265,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static long do_fb_ioctl(struct fb_info *info, unsigned int cmd,
                        unsigned long arg)
  {
-@@ -1084,6 +1108,7 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1082,6 +1106,7 @@ static long do_fb_ioctl(struct fb_info *
        struct fb_fix_screeninfo fix;
        struct fb_cmap cmap_from;
        struct fb_cmap_user cmap;
@@ -273,7 +273,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        void __user *argp = (void __user *)arg;
        long ret = 0;
  
-@@ -1159,6 +1184,15 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1157,6 +1182,15 @@ static long do_fb_ioctl(struct fb_info *
                unlock_fb_info(info);
                console_unlock();
                break;
@@ -289,7 +289,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        default:
                lock_fb_info(info);
                fb = info->fbops;
-@@ -1304,6 +1338,7 @@ static long fb_compat_ioctl(struct file
+@@ -1302,6 +1336,7 @@ static long fb_compat_ioctl(struct file
        case FBIOPAN_DISPLAY:
        case FBIOGET_CON2FBMAP:
        case FBIOPUT_CON2FBMAP:
index 0a8ae1c1791c2ce0900ae45319c8d4b026e7e200..8dd9ed52005bbc2d51d14a94bdf48aaedea7d329 100644 (file)
@@ -500,6 +500,7 @@ CONFIG_BASE_SMALL=0
 # CONFIG_BATTERY_MAX17040 is not set
 # CONFIG_BATTERY_MAX17042 is not set
 # CONFIG_BATTERY_MAX1721X is not set
+# CONFIG_BATTERY_RT5033 is not set
 # CONFIG_BATTERY_SBS is not set
 # CONFIG_BAYCOM_EPP is not set
 # CONFIG_BAYCOM_PAR is not set
index ce93640b553df3717a9f5221dd9d5f05cf805838..120a14c3be3ea2fffe3f777cab76d0074bd9c47d 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Fugang Duan <fugang.duan@nxp.com>
  #include <linux/serial_core.h>
  #include <linux/slab.h>
  #include <linux/tty_flip.h>
-@@ -2391,6 +2393,54 @@ static struct uart_driver lpuart_reg = {
+@@ -2394,6 +2396,54 @@ static struct uart_driver lpuart_reg = {
        .cons           = LPUART_CONSOLE,
  };
  
@@ -82,7 +82,7 @@ Signed-off-by: Fugang Duan <fugang.duan@nxp.com>
  static int lpuart_probe(struct platform_device *pdev)
  {
        const struct of_device_id *of_id = of_match_device(lpuart_dt_ids,
-@@ -2428,6 +2478,10 @@ static int lpuart_probe(struct platform_
+@@ -2431,6 +2481,10 @@ static int lpuart_probe(struct platform_
  
        sport->port.rs485_config = lpuart_config_rs485;
  
index f3ff33028113e64de2ad63b3e9a7d71eb9375e12..5ea3d50c376d48f5523903d8c86e4d733a6dbc9a 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Adriana Reus <adriana.reus@nxp.com>
 
 --- a/drivers/tty/serial/fsl_lpuart.c
 +++ b/drivers/tty/serial/fsl_lpuart.c
-@@ -2476,7 +2476,7 @@ static int lpuart_probe(struct platform_
+@@ -2479,7 +2479,7 @@ static int lpuart_probe(struct platform_
                return PTR_ERR(sport->port.membase);
  
        sport->port.membase += sdata->reg_off;
index 6edcc398d032993ba9c78577a03c19ceb2a8b0b8..f07abc2469a01b51fa0bd70d564b14138900eb1d 100644 (file)
@@ -536,7 +536,7 @@ Signed-off-by: Fugang Duan <fugang.duan@nxp.com>
                lpuart_dma_rx_free(&sport->port);
        }
  
-@@ -2480,6 +2636,10 @@ static int lpuart_probe(struct platform_
+@@ -2483,6 +2639,10 @@ static int lpuart_probe(struct platform_
        sport->port.dev = &pdev->dev;
        sport->port.type = PORT_LPUART;
        sport->devtype = sdata->devtype;
@@ -547,7 +547,7 @@ Signed-off-by: Fugang Duan <fugang.duan@nxp.com>
        ret = platform_get_irq(pdev, 0);
        if (ret < 0)
                return ret;
-@@ -2642,7 +2802,7 @@ static int lpuart_suspend(struct device
+@@ -2645,7 +2805,7 @@ static int lpuart_suspend(struct device
                 * Rx DMA path before suspend and start Rx DMA path on resume.
                 */
                if (irq_wake) {
index ab52567a3cff8a9677120568e069d85b50cd7396..a655a5df019ee48d5327a938e8e8930b18faf25a 100644 (file)
@@ -105,7 +105,7 @@ Signed-off-by: Shrikant Bobade <Shrikant_Bobade@mentor.com>
  static void lpuart_stop_tx(struct uart_port *port)
  {
        unsigned char temp;
-@@ -2728,6 +2770,10 @@ static int lpuart_probe(struct platform_
+@@ -2731,6 +2773,10 @@ static int lpuart_probe(struct platform_
        if (ret)
                goto failed_attach_port;
  
@@ -116,7 +116,7 @@ Signed-off-by: Shrikant Bobade <Shrikant_Bobade@mentor.com>
        uart_get_rs485_mode(&pdev->dev, &sport->port.rs485);
  
        if (sport->port.rs485.flags & SER_RS485_RX_DURING_TX)
-@@ -2751,6 +2797,8 @@ static int lpuart_probe(struct platform_
+@@ -2754,6 +2800,8 @@ static int lpuart_probe(struct platform_
  
        return 0;
  
index d819f4790a1a8f27dff48fe1325ed0168ade3a95..5c0329583bcafc1cb2f0083cba4fed9a750b9fc0 100644 (file)
@@ -59,7 +59,7 @@ Reviewed-by: Robin Gong <yibin.gong@nxp.com>
        .set_termios    = lpuart32_set_termios,
        .type           = lpuart_type,
        .request_port   = lpuart_request_port,
-@@ -2766,6 +2783,11 @@ static int lpuart_probe(struct platform_
+@@ -2769,6 +2786,11 @@ static int lpuart_probe(struct platform_
        if (ret)
                goto failed_irq_request;
  
@@ -71,7 +71,7 @@ Reviewed-by: Robin Gong <yibin.gong@nxp.com>
        ret = uart_add_one_port(&lpuart_reg, &sport->port);
        if (ret)
                goto failed_attach_port;
-@@ -2800,6 +2822,9 @@ static int lpuart_probe(struct platform_
+@@ -2803,6 +2825,9 @@ static int lpuart_probe(struct platform_
  failed_reset:
        uart_remove_one_port(&lpuart_reg, &sport->port);
  failed_attach_port:
@@ -81,7 +81,7 @@ Reviewed-by: Robin Gong <yibin.gong@nxp.com>
  failed_irq_request:
        lpuart_disable_clks(sport);
  failed_clock_enable:
-@@ -2826,15 +2851,41 @@ static int lpuart_remove(struct platform
+@@ -2829,15 +2854,41 @@ static int lpuart_remove(struct platform
        if (sport->dma_rx_chan)
                dma_release_channel(sport->dma_rx_chan);
  
@@ -123,7 +123,7 @@ Reviewed-by: Robin Gong <yibin.gong@nxp.com>
  
        if (lpuart_is_32(sport)) {
                /* disable Rx/Tx and interrupts */
-@@ -2848,10 +2899,14 @@ static int lpuart_suspend(struct device
+@@ -2851,10 +2902,14 @@ static int lpuart_suspend(struct device
                writeb(temp, sport->port.membase + UARTCR2);
        }
  
@@ -138,7 +138,7 @@ Reviewed-by: Robin Gong <yibin.gong@nxp.com>
  
        if (sport->lpuart_dma_rx_use) {
                /*
-@@ -2882,9 +2937,6 @@ static int lpuart_suspend(struct device
+@@ -2885,9 +2940,6 @@ static int lpuart_suspend(struct device
                dmaengine_terminate_all(sport->dma_tx_chan);
        }
  
@@ -148,7 +148,7 @@ Reviewed-by: Robin Gong <yibin.gong@nxp.com>
        return 0;
  }
  
-@@ -2892,9 +2944,11 @@ static int lpuart_resume(struct device *
+@@ -2895,9 +2947,11 @@ static int lpuart_resume(struct device *
  {
        struct lpuart_port *sport = dev_get_drvdata(dev);
        bool irq_wake = irqd_is_wakeup_set(irq_get_irq_data(sport->port.irq));
@@ -162,7 +162,7 @@ Reviewed-by: Robin Gong <yibin.gong@nxp.com>
  
        if (lpuart_is_32(sport))
                lpuart32_setup_watermark_enable(sport);
-@@ -2915,13 +2969,23 @@ static int lpuart_resume(struct device *
+@@ -2918,13 +2972,23 @@ static int lpuart_resume(struct device *
        if (lpuart_is_32(sport))
                lpuart32_configure(sport);
  
@@ -188,7 +188,7 @@ Reviewed-by: Robin Gong <yibin.gong@nxp.com>
  
  static struct platform_driver lpuart_driver = {
        .probe          = lpuart_probe,
-@@ -2929,7 +2993,7 @@ static struct platform_driver lpuart_dri
+@@ -2932,7 +2996,7 @@ static struct platform_driver lpuart_dri
        .driver         = {
                .name   = "fsl-lpuart",
                .of_match_table = lpuart_dt_ids,
index 69dc1b465a04dd8f7281568588b219e74c2a1ed2..1f42e5cb5d110f980381497836b6836e83a8c80b 100644 (file)
@@ -117,7 +117,7 @@ Signed-off-by: Fugang Duan <fugang.duan@nxp.com>
        return 0;
  }
  
-@@ -2876,108 +2890,205 @@ static int lpuart_runtime_resume(struct
+@@ -2879,108 +2893,205 @@ static int lpuart_runtime_resume(struct
        return lpuart_enable_clks(sport);
  };
  
index 4223d1e2f23803d6720225be113aae08e9ffdfe0..522d7023cad962dc7e5de7a855b804e5b85c1a30 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Peng Fan <peng.fan@nxp.com>
 
 --- a/drivers/tty/serial/fsl_lpuart.c
 +++ b/drivers/tty/serial/fsl_lpuart.c
-@@ -2614,7 +2614,9 @@ static int __init lpuart32_early_console
+@@ -2617,7 +2617,9 @@ static int __init lpuart32_early_console
        if (!device->port.membase)
                return -ENODEV;