at91: build images for AT91SAMA5D3XPLAINED
authorFlorian Fainelli <florian@openwrt.org>
Wed, 3 Sep 2014 03:11:25 +0000 (03:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 3 Sep 2014 03:11:25 +0000 (03:11 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 42418

target/linux/at91/image/Makefile
target/linux/at91/sama5d3/profiles/atmel.mk [new file with mode: 0644]

index c2e1d84672fd1c5fc00496c8863a9175521c3560..a44489ca54073657da34b28f42fbf5de78105be6 100644 (file)
@@ -46,6 +46,7 @@ Image/Build/Kernel/AT91SAM9G35EK=$(call MkuImageDtb,9g35ek,at91sam9g35ek)
 Image/Build/Kernel/AT91SAM9M10G45EK=$(call MkuImageDtb,9m10g45ek,at91sam9m10g45ek)
 Image/Build/Kernel/AT91SAM9X25EK=$(call MkuImageDtb,9x25ek,at91sam9x25ek)
 Image/Build/Kernel/AT91SAM9X35EK=$(call MkuImageDtb,9x35ek,at91sam9x35ek)
+Image/Build/Kernel/AT91SAMA5D3XPLAINED=$(call MkuImageDtb,sama5,at91-sama5d3_xplained)
 # CalAmp
 Image/Build/Kernel/LMU5000=$(call MkuImageDtb,lmu5000,lmu5000)
 # Calao
@@ -68,6 +69,7 @@ define Image/Build/Kernel/Default
        $(call Image/Build/Kernel/AT91SAM9M10G45EK)
        $(call Image/Build/Kernel/AT91SAM9X25EK)
        $(call Image/Build/Kernel/AT91SAM9X35EK)
+       $(call Image/Build/Kernel/AT91SAMA5D3XPLAINED)
        $(call Image/Build/Kernel/LMU5000)
        $(call Image/Build/Kernel/TNYA9260)
        $(call Image/Build/Kernel/TNYA9263)
diff --git a/target/linux/at91/sama5d3/profiles/atmel.mk b/target/linux/at91/sama5d3/profiles/atmel.mk
new file mode 100644 (file)
index 0000000..8a9b1ef
--- /dev/null
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/AT91SAMA5D3XPLAINED
+       NAME:=Atmel AT91SAMA5D3XPLAINED
+endef
+define Profile/AT91SAMA5D3XPLAINED/Description
+       Atmel AT91SAMA5D3EXPLAINED eval board
+endef
+$(eval $(call Profile,AT91SAMA5D3XPLAINED))