kernel: make uas work during early boot
authorDaniel Albers <daniel.albers@public-files.de>
Thu, 28 Dec 2017 17:36:24 +0000 (18:36 +0100)
committerJohn Crispin <john@phrozen.org>
Tue, 2 Jan 2018 13:29:04 +0000 (14:29 +0100)
Add the uas(p) module to the modules loaded early on the boot process.

The uas(p) is an modern alternative, which is used by the modern USB3
storage cases, compared to the bot protocol. To be able to use uas(p)
storage cases for extroot, the kernel module has to be loaded before the
search for extroot has been called. This patch changes the load order to
support uas(p) storage cases for extroot.

Signed-off-by: Daniel Albers <daniel.albers@public-files.de>
package/kernel/linux/modules/usb.mk

index d1fb5f4cd23a2d1e7fd2514558563bad1ef4953e..08e3bf699e6e8b301a8befbe9b3157581802786e 100644 (file)
@@ -894,7 +894,7 @@ define KernelPackage/usb-storage-uas
   DEPENDS:=+kmod-usb-storage
   KCONFIG:=CONFIG_USB_UAS
   FILES:=$(LINUX_DIR)/drivers/usb/storage/uas.ko
   DEPENDS:=+kmod-usb-storage
   KCONFIG:=CONFIG_USB_UAS
   FILES:=$(LINUX_DIR)/drivers/usb/storage/uas.ko
-  AUTOLOAD:=$(call AutoProbe,uas)
+  AUTOLOAD:=$(call AutoProbe,uas,1)
 endef
 
 define KernelPackage/usb-storage-uas/description
 endef
 
 define KernelPackage/usb-storage-uas/description