target.mk: check that CPU_TYPE has known CPU_CFLAGS mapping
authorPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 4 Jan 2017 01:15:15 +0000 (18:15 -0700)
committerFelix Fietkau <nbd@nbd.name>
Tue, 4 Apr 2017 10:34:13 +0000 (12:34 +0200)
If someone creates a target and indicates a CPU_TYPE, but there's
no corresponding support for that CPU_TYPE's flags in include/target.mk
then that should probably be indicated rather than silently ignored.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
include/target.mk

index 61489cabe707225d25d89d210700ce76ce810a8c..3523d045ae5e221e966e402706929aca1c697b9b 100644 (file)
@@ -218,6 +218,11 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_arc700 = -mcpu=arc700
     CPU_CFLAGS_archs = -mcpu=archs
   endif
+  ifneq ($(CPU_TYPE),)
+    ifndef CPU_CFLAGS_$(CPU_TYPE)
+      $(warning CPU_TYPE "$(CPU_TYPE)" doesn't correspond to a known type)
+    endif
+  endif
   DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))
 
   ifneq ($(BOARD),)