build: remove backwards compatibility for PKG_USE_MIPS16
authorAndre Heider <a.heider@gmail.com>
Thu, 23 Mar 2023 09:13:43 +0000 (10:13 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 12 May 2023 11:06:14 +0000 (13:06 +0200)
All package feeds have been refactored to PKG_BUILD_FLAGS:=no-mips16.

Signed-off-by: Andre Heider <a.heider@gmail.com>
include/package.mk

index d80f3bce49f4c946f9d6c814c976e9f31f6cdb0b..f03cb15f05d5ac7e50e31104757e5cb46148d26c 100644 (file)
@@ -24,12 +24,6 @@ PKG_JOBS?=$(if $(PKG_BUILD_PARALLEL),$(MAKE_J),-j1)
 endif
 
 PKG_BUILD_FLAGS?=
-# TODO remove this when all packages moved to PKG_BUILD_FLAGS=no-mips16
-PKG_USE_MIPS16?=1
-ifneq ($(strip $(PKG_USE_MIPS16)),1)
-  PKG_BUILD_FLAGS+=no-mips16
-endif
-
 __unknown_flags=$(filter-out no-iremap no-mips16 gc-sections no-gc-sections lto no-lto,$(PKG_BUILD_FLAGS))
 ifneq ($(__unknown_flags),)
   $(error unknown PKG_BUILD_FLAGS: $(__unknown_flags))