kernel: update 4.9 to 4.9.49
authorStijn Tintel <stijn@linux-ipv6.be>
Sun, 10 Sep 2017 21:37:48 +0000 (23:37 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Sun, 10 Sep 2017 23:56:14 +0000 (01:56 +0200)
Refresh patches.
Compile-tested on octeon and x86/64.
Runtime-tested on octeon and x86/64.

Fixes CVE-2017-11600.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
include/kernel-version.mk
target/linux/generic/pending-4.9/811-pci_disable_usb_common_quirks.patch
target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/mediatek/patches-4.9/0062-mdio-atomic.patch

index 89d2a46bfa7bd2ef22a61a30fb5f1762a16a1568..25ef3d6c4fce0635d227024c1a8f453d8bc86994 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
 LINUX_VERSION-4.4 = .87
-LINUX_VERSION-4.9 = .47
+LINUX_VERSION-4.9 = .49
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
 LINUX_KERNEL_HASH-4.4.87 = 1ab05222c3c55e062c3f7418976137ee529f92174261ccb0cd5a7d3370ff6f5b
-LINUX_KERNEL_HASH-4.9.47 = 75be9679d69460a45e77a61474a6d8eee34de21b9929fe4992971dff122541c9
+LINUX_KERNEL_HASH-4.9.49 = 57ecdcf180b56356b2e15264ca567a8fcd9eec993fc70286bec3bd0005e791fb
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index e2d8a3271302033b52bb752bfad03a0234a53929..9dbb2ca8cd10b9fcedfb43c7d71128ea39c83cb0 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static struct amd_chipset_info {
        struct pci_dev  *nb_dev;
        struct pci_dev  *smbus_dev;
-@@ -510,6 +512,10 @@ void usb_amd_dev_put(void)
+@@ -511,6 +513,10 @@ void usb_amd_dev_put(void)
  }
  EXPORT_SYMBOL_GPL(usb_amd_dev_put);
  
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /*
   * Make sure the controller is completely inactive, unable to
   * generate interrupts or do DMA.
-@@ -589,8 +595,17 @@ reset_needed:
+@@ -590,8 +596,17 @@ reset_needed:
        uhci_reset_hc(pdev, base);
        return 1;
  }
@@ -48,7 +48,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -1157,3 +1172,4 @@ static void quirk_usb_early_handoff(stru
+@@ -1158,3 +1173,4 @@ static void quirk_usb_early_handoff(stru
  }
  DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
                        PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);
index 59f3b1ae9f77ae5981d0e6e93b23643769e3fdc6..91a6acce3a9374a813b2da1c51a3b6985900c7db 100644 (file)
@@ -5505,7 +5505,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                                         unsigned long type);
 --- a/include/linux/pci_ids.h
 +++ b/include/linux/pci_ids.h
-@@ -1055,6 +1055,12 @@
+@@ -1056,6 +1056,12 @@
  #define PCI_DEVICE_ID_SGI_LITHIUM     0x1002
  #define PCI_DEVICE_ID_SGI_IOC4                0x100a
  
index 040084d781a9bae7eea5f3934cccfbb807357cc7..96e7072a33964d5386086cae90296aebca84b4cd 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-4.9.47/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-===================================================================
---- linux-4.9.47.orig/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-+++ linux-4.9.47/drivers/net/ethernet/mediatek/mtk_eth_soc.c
+--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
++++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
 @@ -97,7 +97,10 @@ static int mtk_mdio_busy_wait(struct mtk
                        return 0;
                if (time_after(jiffies, t_start + PHY_IAC_TIMEOUT))