add hostap kernel driver
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Oct 2005 13:21:05 +0000 (13:21 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Oct 2005 13:21:05 +0000 (13:21 +0000)
SVN-Revision: 2278

openwrt/target/linux/package/Config.in
openwrt/target/linux/package/Makefile
openwrt/target/linux/package/hostap/Config.in [new file with mode: 0644]
openwrt/target/linux/package/hostap/Makefile [new file with mode: 0644]
openwrt/target/linux/package/hostap/ipkg/kmod-hostap-pci.control [new file with mode: 0644]
openwrt/target/linux/package/hostap/ipkg/kmod-hostap-plx.control [new file with mode: 0644]
openwrt/target/linux/package/hostap/ipkg/kmod-hostap.control [new file with mode: 0644]

index 2425f422365dd9c6ce02e2a7753f587145b1a8e9..0bf091eae4354d42fc07dd99be6f2529e87d25cb 100644 (file)
@@ -1,8 +1,9 @@
 source "target/linux/package/wlcompat/Config.in"
 source "target/linux/package/diag/Config.in"
-source "target/linux/package/madwifi/Config.in"
 source "target/linux/package/alsa/Config.in"
 source "target/linux/package/fuse/Config.in"
+source "target/linux/package/hostap/Config.in"
+source "target/linux/package/madwifi/Config.in"
 source "target/linux/package/mini_fo/Config.in"
-source "target/linux/package/shfs/Config.in"
 source "target/linux/package/openswan/Config.in"
+source "target/linux/package/shfs/Config.in"
index ad9b21a2ec36b0d882f5258c6570ce289d2be035..99e8b6a0fb99c04b41ffa72a53a72f8decc560c5 100644 (file)
@@ -5,6 +5,7 @@ ifneq ($(BOARD),ar7)
 package-$(BR2_PACKAGE_KMOD_ALSA) += alsa
 endif
 package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
+package-$(BR2_PACKAGE_KMOD_HOSTAP) += hostap
 package-$(BR2_PACKAGE_KMOD_MINI_FO) += mini_fo
 package-$(BR2_PACKAGE_KMOD_SHFS) += shfs
 package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
diff --git a/openwrt/target/linux/package/hostap/Config.in b/openwrt/target/linux/package/hostap/Config.in
new file mode 100644 (file)
index 0000000..539e943
--- /dev/null
@@ -0,0 +1,48 @@
+config BR2_PACKAGE_KMOD_HOSTAP
+       prompt "kmod-hostap - Host AP support for Prism2/2.5/3 IEEE 802.11b"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         A driver for 802.11b wireless cards based on Intersil Prism2/2.5/3
+         chipset. This driver supports so called Host AP mode that allows
+         the card to act as an IEEE 802.11 access point.
+         
+         This option includes the base Host AP driver code that is shared by
+         different hardware models. You will also need to enable support for
+         PLX/PCI/CS version of the driver to actually use the driver.
+         
+         http://hostap.epitest.fi/
+         
+         This package contains the hostap.o and hostap_crypt_wep.o kernel modules.
+         
+
+config BR2_PACKAGE_KMOD_HOSTAP_PCI
+       prompt "kmod-hostap-pci - Host AP driver for Prism2.5 PCI adaptors"
+       tristate
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_KMOD_HOSTAP
+       help
+         Host AP support for Prism2/2.5/3 IEEE 802.11b" is required for this
+         driver and its help text includes more information about the Host AP
+         driver.
+         
+         http://hostap.epitest.fi/
+         
+         This package contains the hostap_pci.o kernel module.
+         
+
+config BR2_PACKAGE_KMOD_HOSTAP_PLX
+       prompt "kmod-hostap-plx - Host AP driver for Prism2/2.5/3 in PLX9052 based PCI adaptors"
+       tristate
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_KMOD_HOSTAP
+       help
+         Host AP support for Prism2/2.5/3 IEEE 802.11b" is required for this
+         driver and its help text includes more information about the Host AP
+         driver.
+         
+         http://hostap.epitest.fi/
+         
+         This package contains the hostap_plx.o kernel module.
+         
+
diff --git a/openwrt/target/linux/package/hostap/Makefile b/openwrt/target/linux/package/hostap/Makefile
new file mode 100644 (file)
index 0000000..69d5ae6
--- /dev/null
@@ -0,0 +1,63 @@
+# $Id: Makefile 1832 2005-09-03 19:27:27Z wbx $
+
+include $(TOPDIR)/rules.mk
+include ../../rules.mk
+
+PKG_NAME:=hostap-driver
+PKG_VERSION:=0.4.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=8ee17f206e035075b20fcba96b168234
+
+PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+ifeq ($(KERNEL_DIR),)
+KERNEL_DIR:=$(LINUX_DIR)
+endif
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,KMOD_HOSTAP,kmod-hostap,$(LINUX_VERSION)$(BOARD)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(KERNEL_RELEASE))))
+$(eval $(call PKG_template,KMOD_HOSTAP_PCI,kmod-hostap-pci,$(LINUX_VERSION)$(BOARD)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(KERNEL_RELEASE))))
+$(eval $(call PKG_template,KMOD_HOSTAP_PLX,kmod-hostap-plx,$(LINUX_VERSION)$(BOARD)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(KERNEL_RELEASE))))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built: 
+       $(MAKE) -C $(KERNEL_DIR)/ \
+               SUBDIRS="$(PKG_BUILD_DIR)/driver/modules" \
+               modules
+       touch $@
+
+$(IPKG_KMOD_HOSTAP):
+       install -m0755 -d $(IDIR_KMOD_HOSTAP)/lib/modules/$(LINUX_VERSION)
+       cp -fpR \
+               $(PKG_BUILD_DIR)/driver/modules/hostap.o \
+               $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_ccmp.o \
+               $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_tkip.o \
+               $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_wep.o \
+               $(IDIR_KMOD_HOSTAP)/lib/modules/$(LINUX_VERSION)/
+       $(RSTRIP_KMOD) $(IDIR_KMOD_HOSTAP)
+       $(IPKG_BUILD) $(IDIR_KMOD_HOSTAP) $(PACKAGE_DIR)
+
+$(IPKG_KMOD_HOSTAP_PCI):
+       install -m0755 -d $(IDIR_KMOD_HOSTAP_PCI)/lib/modules/$(LINUX_VERSION)
+       cp -fpR \
+               $(PKG_BUILD_DIR)/driver/modules/hostap_pci.o \
+               $(IDIR_KMOD_HOSTAP_PCI)/lib/modules/$(LINUX_VERSION)/
+       $(RSTRIP_KMOD) $(IDIR_KMOD_HOSTAP_PCI)
+       $(IPKG_BUILD) $(IDIR_KMOD_HOSTAP_PCI) $(PACKAGE_DIR)
+
+$(IPKG_KMOD_HOSTAP_PLX):
+       install -m0755 -d $(IDIR_KMOD_HOSTAP_PLX)/lib/modules/$(LINUX_VERSION)
+       cp -fpR \
+               $(PKG_BUILD_DIR)/driver/modules/hostap_plx.o \
+               $(IDIR_KMOD_HOSTAP_PLX)/lib/modules/$(LINUX_VERSION)/
+       $(RSTRIP_KMOD) $(IDIR_KMOD_HOSTAP_PLX)
+       $(IPKG_BUILD) $(IDIR_KMOD_HOSTAP_PLX) $(PACKAGE_DIR)
+
diff --git a/openwrt/target/linux/package/hostap/ipkg/kmod-hostap-pci.control b/openwrt/target/linux/package/hostap/ipkg/kmod-hostap-pci.control
new file mode 100644 (file)
index 0000000..3c3cdf8
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-hostap-pci
+Priority: optional
+Section: net
+Depends: kmod-hostap
+Description: Host AP driver for Prism2.5 PCI adaptors
diff --git a/openwrt/target/linux/package/hostap/ipkg/kmod-hostap-plx.control b/openwrt/target/linux/package/hostap/ipkg/kmod-hostap-plx.control
new file mode 100644 (file)
index 0000000..6e039b8
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-hostap-plx
+Priority: optional
+Section: net
+Depends: kmod-hostap
+Description: Host AP driver for Prism2/2.5/3 in PLX9052 based PCI adaptors
diff --git a/openwrt/target/linux/package/hostap/ipkg/kmod-hostap.control b/openwrt/target/linux/package/hostap/ipkg/kmod-hostap.control
new file mode 100644 (file)
index 0000000..e5efb4e
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-hostap
+Priority: optional
+Section: net
+Description: Host AP support for Prism2/2.5/3 IEEE 802.11b