base-files: add ucidef_add_switch_port function
authorLuka Perkov <luka@openwrt.org>
Thu, 23 Jan 2014 11:33:41 +0000 (11:33 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 23 Jan 2014 11:33:41 +0000 (11:33 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 39372

package/base-files/Makefile
package/base-files/files/lib/functions/uci-defaults.sh

index d6c59384ee118afcb64e0a0e2576ebd5f28e258e..33c0c5b24d505ae4149faa80bebf270ce128aa36 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=150
+PKG_RELEASE:=151
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index bf6fe1e3057245c4825c2c49138cebc36a39c544..da2093bbb7bf44b687d513b577f16f56980b690e 100644 (file)
@@ -234,3 +234,13 @@ set network.@switch_vlan[-1].ports='$ports'
 EOF
 }
 
+ucidef_add_switch_port() {
+       local device=$1
+       local port=$2
+       uci batch <<EOF
+add network switch_port
+set network.@switch_port[-1].device='$device'
+set network.@switch_port[-1].port='$port'
+EOF
+}
+