build: keep recursive dependency check stampfiles up to date
authorFelix Fietkau <nbd@nbd.name>
Wed, 1 Feb 2017 13:44:22 +0000 (14:44 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 1 Feb 2017 13:45:13 +0000 (14:45 +0100)
Since the main stamp file depends on the _check stampfile, the _check
stampfile needs to be created on the first run as well.

Fixes spurious rebuilds with CONFIG_AUTOREBUILD=y

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/package.mk

index 91871f06fbebf24245df3467757175cd1ed6aa51..ce1aa256bdf0eaf78c298fcba0f207e6ca9047fc 100644 (file)
@@ -156,6 +156,7 @@ define Build/CoreTargets
   $(STAMP_PREPARED): $(STAMP_PREPARED_DEPENDS)
        @-rm -rf $(PKG_BUILD_DIR)
        @mkdir -p $(PKG_BUILD_DIR)
+       touch $$@_check
        $(foreach hook,$(Hooks/Prepare/Pre),$(call $(hook))$(sep))
        $(Build/Prepare)
        $(foreach hook,$(Hooks/Prepare/Post),$(call $(hook))$(sep))
@@ -172,6 +173,8 @@ define Build/CoreTargets
 
   $(call Build/Exports,$(STAMP_BUILT))
   $(STAMP_BUILT): $(STAMP_CONFIGURED) $(STAMP_BUILT_DEPENDS)
+       rm -f $$@
+       touch $$@_check
        $(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
        $(Build/Compile)
        $(foreach hook,$(Hooks/Compile/Post),$(call $(hook))$(sep))