map: drop default encaplimit value
authorHans Dedecker <dedeckeh@gmail.com>
Mon, 17 Sep 2018 15:53:34 +0000 (17:53 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Wed, 19 Sep 2018 07:42:45 +0000 (09:42 +0200)
Setting encaplimit to a numerical value results into the value being
included as tunnel encapsulation limit in the destination option header
for tunneled packets.
Several users have reported interop issues as not all ISPs support the
destination option header containing the tunnel encapsulation limit
resulting into broken map connectivity.
Therefore drop the default encaplimit value for map tunnels so
no destination option header is included by default.

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/ipv6/map/Makefile
package/network/ipv6/map/files/map.sh

index cfb7c4ac357e6f4942978611ac42c5ccb99024b9..10dbe97b4889d16615328d7a1a75f44604e592ec 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
 PKG_VERSION:=4
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index 5f4add36eb80210b41375ac865aadbc79804903f..70dc72326c4657b375b542e7f31d9ddb7aefe1d7 100755 (executable)
@@ -85,7 +85,7 @@ proto_map_setup() {
                json_add_string remote $(eval "echo \$RULE_${k}_BR")
                json_add_string link $(eval "echo \$RULE_${k}_PD6IFACE")
                json_add_object "data"
-                       json_add_string encaplimit "${encaplimit:-4}"
+                       [ -n "$encaplimit" ] && json_add_string encaplimit "$encaplimit"
                        if [ "$type" = "map-e" ]; then
                                json_add_array "fmrs"
                                for i in $(seq $RULE_COUNT); do