openssl: always build with EC support
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Mon, 5 Aug 2019 18:34:37 +0000 (15:34 -0300)
committerJo-Philipp Wich <jo@mein.io>
Wed, 4 Sep 2019 11:45:34 +0000 (13:45 +0200)
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit f40262697f5aebed25313a1b2eb8f68d37c97e60)

package/libs/openssl/Config.in
package/libs/openssl/Makefile

index 63493829ba4879f98c6db9232711ad6dd5649055..d1281ec6fa09b5f6fd3de5f7c7758668ebc6286d 100644 (file)
@@ -76,7 +76,6 @@ config OPENSSL_WITH_TLS13
        bool
        default y
        prompt "Enable support for TLS 1.3"
        bool
        default y
        prompt "Enable support for TLS 1.3"
-       select OPENSSL_WITH_EC
        help
                TLS 1.3 is the newest version of the TLS specification.
                It aims:
        help
                TLS 1.3 is the newest version of the TLS specification.
                It aims:
@@ -120,19 +119,8 @@ config OPENSSL_WITH_CMS
 
 comment "Algorithm Selection"
 
 
 comment "Algorithm Selection"
 
-config OPENSSL_WITH_EC
-       bool
-       default y
-       prompt "Enable elliptic curve support"
-       help
-               Elliptic-curve cryptography (ECC) is an approach to public-key
-               cryptography based on the algebraic structure of elliptic curves
-               over finite fields. ECC requires smaller keys compared to non-ECC
-               cryptography to provide equivalent security.
-
 config OPENSSL_WITH_EC2M
        bool
 config OPENSSL_WITH_EC2M
        bool
-       depends on OPENSSL_WITH_EC
        prompt "Enable ec2m support"
        help
                This option enables the more efficient, yet less common, binary
        prompt "Enable ec2m support"
        help
                This option enables the more efficient, yet less common, binary
index f16c24f7c6a3c23ec1b7c53903abb29ce44bbe2b..5663fd4b95ec3a0b3c33405343fe7461054aa9a9 100644 (file)
@@ -11,7 +11,7 @@ PKG_NAME:=openssl
 PKG_BASE:=1.1.1
 PKG_BUGFIX:=c
 PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
 PKG_BASE:=1.1.1
 PKG_BUGFIX:=c
 PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 ENGINES_DIR=engines-1.1
 
 PKG_USE_MIPS16:=0
 ENGINES_DIR=engines-1.1
 
@@ -28,7 +28,7 @@ PKG_HASH:=f6fb3079ad15076154eda9413fed42877d668e7069d9b87396d0804fdb3f4c90
 
 PKG_LICENSE:=OpenSSL
 PKG_LICENSE_FILES:=LICENSE
 
 PKG_LICENSE:=OpenSSL
 PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
+PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
 PKG_CPE_ID:=cpe:/a:openssl:openssl
 PKG_CONFIG_DEPENDS:= \
        CONFIG_OPENSSL_ENGINE \
 PKG_CPE_ID:=cpe:/a:openssl:openssl
 PKG_CONFIG_DEPENDS:= \
        CONFIG_OPENSSL_ENGINE \
@@ -48,7 +48,6 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_OPENSSL_WITH_CMS \
        CONFIG_OPENSSL_WITH_COMPRESSION \
        CONFIG_OPENSSL_WITH_DTLS \
        CONFIG_OPENSSL_WITH_CMS \
        CONFIG_OPENSSL_WITH_COMPRESSION \
        CONFIG_OPENSSL_WITH_DTLS \
-       CONFIG_OPENSSL_WITH_EC \
        CONFIG_OPENSSL_WITH_EC2M \
        CONFIG_OPENSSL_WITH_ERROR_MESSAGES \
        CONFIG_OPENSSL_WITH_GOST \
        CONFIG_OPENSSL_WITH_EC2M \
        CONFIG_OPENSSL_WITH_ERROR_MESSAGES \
        CONFIG_OPENSSL_WITH_GOST \
@@ -203,10 +202,6 @@ ifndef CONFIG_OPENSSL_WITH_ASYNC
   OPENSSL_OPTIONS += no-async
 endif
 
   OPENSSL_OPTIONS += no-async
 endif
 
-ifndef CONFIG_OPENSSL_WITH_EC
-  OPENSSL_OPTIONS += no-ec
-endif
-
 ifndef CONFIG_OPENSSL_WITH_EC2M
   OPENSSL_OPTIONS += no-ec2m
 endif
 ifndef CONFIG_OPENSSL_WITH_EC2M
   OPENSSL_OPTIONS += no-ec2m
 endif