ipq40xx: copy Fritz4040 UBoot to STAGING_DIR_IMAGE
authorDavid Bauer <mail@david-bauer.net>
Fri, 4 Jan 2019 20:17:20 +0000 (21:17 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Mon, 18 Mar 2019 19:41:02 +0000 (20:41 +0100)
Copy U-Boot to STAGING_DIR_IMAGE (and append it to the EVA-image from
there) to fix image generation using the image-builder.

Also remove the bootloader from DEVICE_PACKAGES and instead use the
BUILD_DEVICES directive from within the U-Boot makefile.

This fixes eva-image generation using the OpenWRT image-builder.

Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit 634c733065256979835ca3d7218ae8203a693683)

package/boot/uboot-fritz4040/Makefile
target/linux/ipq40xx/image/Makefile

index 77d6fdc3b8bba3a646d4d24a9618a00497f9b7e8..659bd0d084203861dd69ab18ead1dc4bcc48a4e0 100644 (file)
@@ -21,11 +21,12 @@ include $(INCLUDE_DIR)/package.mk
 
 define U-Boot/Default
   BUILD_TARGET:=ipq40xx
-  UBOOT_IMAGE:=uboot-fritz4040.bin
 endef
 
 define U-Boot/fritz4040
   NAME:=FritzBox 4040
+  UBOOT_IMAGE:=uboot-fritz4040.bin
+  BUILD_DEVICES:=avm_fritzbox-4040
 endef
 
 UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
@@ -45,6 +46,11 @@ define Build/Compile
        (cd $(PKG_BUILD_DIR); ./fritz/fritzcreator.sh;)
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(UBOOT_IMAGE)
+endef
+
 define Package/u-boot/install
        $(Package/u-boot/install/default)
        $(INSTALL_BIN) ./files/upload-to-f4040.sh $(1)/
index 38600cf979242142aa08c30163e63d911f0ddb63..90d9dfeff0c228765ac24247ce72dec497dc63f0 100644 (file)
@@ -80,12 +80,12 @@ define Device/avm_fritzbox-4040
        BOARD_NAME := fritz4040
        DEVICE_TITLE := AVM Fritz!Box 4040
        IMAGE_SIZE := 29753344
-       UBOOT_PATH := $$(BIN_DIR)/u-boot-fritz4040/uboot-fritz4040.bin
+       UBOOT_PATH := $(STAGING_DIR_IMAGE)/uboot-fritz4040.bin
        UBOOT_PARTITION_SIZE := 524288
        IMAGES = eva.bin sysupgrade.bin
        IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := fritz-tffs fritz-caldata u-boot-fritz4040
+       DEVICE_PACKAGES := fritz-tffs fritz-caldata
 endef
 TARGET_DEVICES += avm_fritzbox-4040