ath10k-ct: fix module depends
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 22 Mar 2018 22:24:42 +0000 (23:24 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 23 Mar 2018 21:08:22 +0000 (22:08 +0100)
PKG_EXTMOD_SUBDIRS should be set to the sub directory where the kernel
module gets build in, for the ath10k-ct driver this changed in commit
3888e77c1c68 from ath10k to ath10k-4.13. Without this fix the depends
line of the ath10*.ko modules is empty and the kernel module load system
will not automatically load the depended modules like mac80211.

Fixes: 3888e77c1c68 ("ath10k-ct driver: use dma_alloc_coherent, 4.13 based driver")
Fixes: 23a388fe41ec ("ath10k-ct: Force loading mac80211 and ath modules.")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/ath10k-ct/Makefile

index 00931175c2728c88643bd9b9a43739726be81903..1725bb7d173fe5ac6d92b35c68ecd7a231348c59 100644 (file)
@@ -12,15 +12,15 @@ PKG_SOURCE_DATE:=2018-03-16
 PKG_SOURCE_VERSION:=30827f7d5b9841905c4efe918da2d95fc518c921
 PKG_MIRROR_HASH:=aac023d7f9b09becf27058b1d09ae6d068b14bb6f10c5b5a248c7ee5ecff04dc
 
-PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
-PKG_BUILD_PARALLEL:=1
-PKG_EXTMOD_SUBDIRS:=ath10k
-
 # Build the 4.13 ath10k-ct driver version.  Other options are "-4.9", or
 # leave un-defined for 4.7 kernel.  Probably this should match as closely as
 # possible to whatever mac80211 backports version is being used.
 CT_KVER="-4.13"
 
+PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
+PKG_BUILD_PARALLEL:=1
+PKG_EXTMOD_SUBDIRS:=ath10k$(CT_KVER)
+
 STAMP_CONFIGURED_DEPENDS := $(STAGING_DIR)/usr/include/mac80211-backport/backport/autoconf.h
 
 include $(INCLUDE_DIR)/kernel.mk
@@ -33,7 +33,7 @@ define KernelPackage/ath10k-ct
   FILES:=\
        $(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_pci.ko \
        $(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_core.ko
-  AUTOLOAD:=$(call AutoProbe,mac80211 ath ath10k_pci)
+  AUTOLOAD:=$(call AutoProbe,ath10k_pci)
   PROVIDES:=kmod-ath10k
 endef