standardize Makefile
authorNicolas Thill <nico@openwrt.org>
Sat, 23 Sep 2006 19:32:32 +0000 (19:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 23 Sep 2006 19:32:32 +0000 (19:32 +0000)
SVN-Revision: 4845

openwrt/package/util-linux/Makefile

index 79517f9dfb01fedde251ae552d8799511c960836..18fb251463682fbff1165f3064f4bcdb1ba1241c 100644 (file)
@@ -11,51 +11,58 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=util-linux
 PKG_VERSION:=2.12r
 PKG_RELEASE:=1
 PKG_NAME:=util-linux
 PKG_VERSION:=2.12r
 PKG_RELEASE:=1
-PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
 
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
 PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
 PKG_CAT:=zcat
 PKG_CAT:=zcat
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/util-linux/Default
+  SECTION:=utils
+  CATEGORY:=Utilities
+  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+endef
+
 define Package/fdisk
 define Package/fdisk
-SECTION:=base
-CATEGORY:=Utilities
-TITLE:=Partition table manipulation utility
-DESCRIPTION:=A partition table manipulation utility
-URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+  $(call Package/util-linux/Default)
+  TITLE:=Partition table manipulation utility
+  DESCRIPTION:=\
+       This package contains an utility for managing disk partition tables.
+  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
 define Package/losetup
 endef
 
 define Package/losetup
-$(call Package/fdisk)
-TITLE:=Loopback devices setup and control utility
-DESCRIPTION:=A loopback devices setup and control utility
+  $(call Package/util-linux/Default)
+  TITLE:=Loopback devices setup and control utility
+  DESCRIPTION:=\
+       This package contains an utility for managing loopback devices.
 endef
 
 define Package/swap-utils
 endef
 
 define Package/swap-utils
-$(call Package/fdisk)
-TITLE:=Swap space management utilities
-DESCRIPTION:=A collection of tools to manage swap space \\\
-    * mkswap\\\
-    * swapon\\\
-    * swapoff
+  $(call Package/util-linux/Default)
+  TITLE:=Swap space management utilities
+  DESCRIPTION:=\
+       This package contains a collection of tools for managing swap space: \\\
+       - mkswap\\\
+       - swapon\\\
+       - swapoff
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
+       $(call Build/Compile/Default, \
                OPT="$(TARGET_CFLAGS)" \
                OPT="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALLSUID="install -m 4755" \
                INSTALLSUID="install -m 4755" \
-               all install
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install \
+       )
 endef
 
 define Package/Template
 endef
 
 define Package/Template
@@ -70,14 +77,17 @@ endef
 define Package/fdisk/install
        $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
 endef
 define Package/fdisk/install
        $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
 endef
+
 define Package/losetup/install
        $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
 endef
 define Package/losetup/install
        $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
 endef
+
 define Package/swap-utils/install
        $(call Package/Template,sbin/mkswap,$(1)/usr/sbin)
        $(call Package/Template,sbin/swapon,$(1)/usr/sbin)
        $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
 endef
 define Package/swap-utils/install
        $(call Package/Template,sbin/mkswap,$(1)/usr/sbin)
        $(call Package/Template,sbin/swapon,$(1)/usr/sbin)
        $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
 endef
+
 $(eval $(call BuildPackage,fdisk))
 $(eval $(call BuildPackage,losetup))
 $(eval $(call BuildPackage,swap-utils))
 $(eval $(call BuildPackage,fdisk))
 $(eval $(call BuildPackage,losetup))
 $(eval $(call BuildPackage,swap-utils))