ath79: Add support for OpenMesh MR900 v1
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 19 Jan 2021 14:39:36 +0000 (15:39 +0100)
Device specifications:
======================

* Qualcomm/Atheros QCA9558 ver 1 rev 0
* 720/600/240 MHz (CPU/DDR/AHB)
* 128 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 3T3R 2.4 GHz Wi-Fi
* 3T3R 5 GHz Wi-Fi
* 6x GPIO-LEDs (2x wifi, 2x status, 1x lan, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default))
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 1x ethernet
  - AR8035 ethernet PHY (RGMII)
  - 10/100/1000 Mbps Ethernet
  - 802.3af POE
  - used as LAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
[rebase, add LED migration]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9558_openmesh_mr900-v1.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9558_openmesh_mr900.dtsi [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 028b00ac4366854f0e7c5f84a321a6f24b5d2156..816d3b1a88f1297219c481b301f0de1ad94a7ed6 100644 (file)
@@ -50,6 +50,7 @@ ocedo,koala|\
 ocedo,raccoon|\
 openmesh,mr600-v1|\
 openmesh,mr600-v2|\
 ocedo,raccoon|\
 openmesh,mr600-v1|\
 openmesh,mr600-v2|\
+openmesh,mr900-v1|\
 openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
 openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr900-v1.dts b/target/linux/ath79/dts/qca9558_openmesh_mr900-v1.dts
new file mode 100644 (file)
index 0000000..96fc985
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_openmesh_mr900.dtsi"
+
+/ {
+       compatible = "openmesh,mr900-v1", "qca,qca9558";
+       model = "OpenMesh MR900 v1";
+};
diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr900.dtsi b/target/linux/ath79/dts/qca9558_openmesh_mr900.dtsi
new file mode 100644 (file)
index 0000000..e506e12
--- /dev/null
@@ -0,0 +1,182 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca955x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       chosen {
+               /delete-property/ bootargs;
+       };
+
+       aliases {
+               serial0 = &uart;
+               led-boot = &led_power_blue;
+               led-failsafe = &led_power_blue;
+               led-running = &led_power_blue;
+               led-upgrade = &led_power_blue;
+               label-mac-device = &eth0;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               lan_blue {
+                       label = "blue:lan";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi2g_blue {
+                       label = "blue:wifi2g";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               status_green {
+                       label = "green:status";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+               };
+
+               status_red {
+                       label = "red:status";
+                       gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+               };
+
+               led_power_blue: power_blue {
+                       label = "blue:power";
+                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wifi5g_blue {
+                       label = "blue:wifi5g";
+                       gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+
+       watchdog {
+               compatible = "linux,wdt-gpio";
+               gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               hw_algo = "toggle";
+               /* hw_margin_ms is actually 300s but driver limits it to 60s */
+               hw_margin_ms = <60000>;
+               always-running;
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+
+               /* partitions are passed via bootloader */
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@50000 {
+                               label = "custom";
+                               reg = <0x050000 0x060000>;
+                               read-only;
+                       };
+
+                       partition@b0000 {
+                               label = "inactive";
+                               reg = <0x0b0000 0x7a0000>;
+                       };
+
+                       partition@850000 {
+                               label = "inactive2";
+                               reg = <0x850000 0x7a0000>;
+                       };
+
+                       art: partition@ff0000 {
+                               label = "ART";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0x20>;
+
+       phy5: ethernet-phy@5 {
+               reg = <5>;
+               eee-broken-100tx;
+               eee-broken-1000t;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       pll-data = <0xae000000 0xa0000101 0xa0001313>;
+
+       mtd-mac-address = <&art 0x0>;
+
+       phy-mode = "rgmii-rxid";
+       phy-handle = <&phy5>;
+
+       gmac-config {
+               device = <&gmac>;
+               rgmii-enabled = <1>;
+               rxd-delay = <3>;
+               rxdv-delay = <3>;
+               txd-delay = <0>;
+               txen-delay = <0>;
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&art 0x0>;
+       mtd-mac-address-increment = <1>;
+};
+
+&pcie0 {
+       status = "okay";
+
+       wifi@0,0 {
+               compatible = "pci168c,0033";
+               reg = <0x0000 0 0 0 0>;
+               mtd-mac-address = <&art 0x0>;
+               mtd-mac-address-increment = <16>;
+       };
+};
index 9e5e42e268a9523bc73a681d24a747cbd2218d42..034c2d29336c00558e72fe1e83cd6dd43eff45cc 100755 (executable)
@@ -157,7 +157,8 @@ telco,t1)
        ;;
 comfast,cf-wr752ac-v1|\
 engenius,eap300-v2|\
        ;;
 comfast,cf-wr752ac-v1|\
 engenius,eap300-v2|\
-enterasys,ws-ap3705i)
+enterasys,ws-ap3705i|\
+openmesh,mr900-v1)
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
 compex,wpj344-16m|\
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
 compex,wpj344-16m|\
index 3c37781c0e03c780846d0d7c16343ce2eb71f19c..8a15d2ad55be0bf4cd5a00b96a22db6be04542be 100755 (executable)
@@ -48,6 +48,7 @@ ath79_setup_interfaces()
        ocedo,raccoon|\
        openmesh,mr600-v1|\
        openmesh,mr600-v2|\
        ocedo,raccoon|\
        openmesh,mr600-v1|\
        openmesh,mr600-v2|\
+       openmesh,mr900-v1|\
        pcs,cap324|\
        pisen,ts-d084|\
        pisen,wmb001n|\
        pcs,cap324|\
        pisen,ts-d084|\
        pisen,wmb001n|\
index 88c4f527b7dad964f143a4c3028749d7a86ba1d6..ad14eb2941d80126f2e7809101d9d70696763b58 100644 (file)
@@ -23,6 +23,9 @@ openmesh,mr600-v1)
 openmesh,mr600-v2)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
        ;;
 openmesh,mr600-v2)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
        ;;
+openmesh,mr900-v1)
+       migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
+       ;;
 pcs,cap324)
        migrate_leds "lan:amber=amber:lan" "lan:green=green:lan"
        ;;
 pcs,cap324)
        migrate_leds "lan:amber=amber:lan" "lan:green=green:lan"
        ;;
index e14adb38fab6f6c7370e61adb07e39113c159b51..40197cfaa8e6469b54efdae82aa290998b40903e 100644 (file)
@@ -52,6 +52,7 @@ platform_do_upgrade() {
                ;;
        openmesh,mr600-v1|\
        openmesh,mr600-v2|\
                ;;
        openmesh,mr600-v1|\
        openmesh,mr600-v2|\
+       openmesh,mr900-v1|\
        openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
        openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
index 9a182cab79b68f9604d2416b13fd3b2bb5349066..9d6fd398d95c11040b2ba1c4ce798ff4af641796 100644 (file)
@@ -1552,6 +1552,26 @@ define Device/openmesh_mr600-v2
 endef
 TARGET_DEVICES += openmesh_mr600-v2
 
 endef
 TARGET_DEVICES += openmesh_mr600-v2
 
+define Device/openmesh_mr900-common
+  SOC := qca9558
+  DEVICE_VENDOR := OpenMesh
+  DEVICE_MODEL := MR900
+  DEVICE_PACKAGES := uboot-envtools
+  IMAGE_SIZE := 7808k
+  BLOCKSIZE := 64k
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | \
+       pad-to $$(BLOCKSIZE)
+  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
+       openmesh-image ce_type=MR900 | append-metadata
+endef
+
+define Device/openmesh_mr900-v1
+  $(Device/openmesh_mr900-common)
+  DEVICE_VARIANT := v1
+  SUPPORTED_DEVICES += mr900
+endef
+TARGET_DEVICES += openmesh_mr900-v1
+
 define Device/openmesh_om2p-common
   DEVICE_VENDOR := OpenMesh
   DEVICE_PACKAGES := uboot-envtools
 define Device/openmesh_om2p-common
   DEVICE_VENDOR := OpenMesh
   DEVICE_PACKAGES := uboot-envtools