x86: geode: add kmod-crypto-ebc needed for hw acceleration
authorPaul Fertser <fercerpav@gmail.com>
Fri, 21 Jan 2022 17:12:29 +0000 (20:12 +0300)
committerPetr Štetiar <ynezz@true.cz>
Sat, 19 Feb 2022 12:10:01 +0000 (13:10 +0100)
Module kmod-crypto-hw-geode provides accelerated cbc(aes) and ecb(aes)
but the software implementation is also needed when AES key size isn't
128 so that the operation can fall back. Add the kmod so that it would
all work as expected out of the box.

Tested-by: timur_davletshin
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
target/linux/x86/image/geode.mk

index 6cea887926db963638f727f22df78134e49c7d3e..ce5e93a2c5bc2fb59fabed12744286b43caf0e00 100644 (file)
@@ -1,7 +1,8 @@
 define Device/generic
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := x86/Geode
-  DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-hw-geode kmod-ledtrig-gpio
+  DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-ebc kmod-crypto-hw-geode \
+       kmod-ledtrig-gpio
   GRUB2_VARIANT := legacy
 endef
 TARGET_DEVICES += generic