firmware-utils: link statically
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Aug 2012 19:27:08 +0000 (19:27 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Aug 2012 19:27:08 +0000 (19:27 +0000)
SVN-Revision: 33117

tools/firmware-utils/Makefile

index 05b588f3b5d18a3d2a0d083b34ce8d52ef8b3203..640dd23ee539f35429a1470ba671af43ea876d1a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 define cc
-       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -static -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
 define Host/Compile