mvebu: fix initramfs/kernel image for CZNIC Turris Omnia
authorKarel Kočí <karel.koci@nic.cz>
Thu, 22 Oct 2020 11:29:57 +0000 (13:29 +0200)
committerPetr Štetiar <ynezz@true.cz>
Fri, 11 Dec 2020 12:56:29 +0000 (13:56 +0100)
This adds DTB to kernel and that way makes it possible to easily boot
initramfs image and also kernel.

The sequence to boot initramfs on Omnia is then just:
  env set bootargs earlyprintk console=ttyS0,115200
  dhcp 0x1000000 192.168.1.1:openwrt-mvebu-cortexa9-cznic_turris-omnia-initramfs-kernel.bin
  bootz 0x1000000

Without this change kernel boot won't proceed and is stuck on "Starting
kernel".

Signed-off-by: Karel Kočí <karel.koci@nic.cz>
[fixed From: to match with SoB:]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/mvebu/image/cortexa9.mk

index ea20a25a29901b33990b8bb0a667d0efae917e6f..67f68b17708a1f94f117b58ee56415e7482d50da 100644 (file)
@@ -32,8 +32,7 @@ define Device/cznic_turris-omnia
   DEVICE_VENDOR := CZ.NIC
   DEVICE_MODEL := Turris Omnia
   KERNEL_INSTALL := 1
-  KERNEL := kernel-bin
-  KERNEL_INITRAMFS := kernel-bin
+  KERNEL := kernel-bin | append-dtb
   DEVICE_PACKAGES :=  \
     mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
     wpad-basic-wolfssl kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \