lldpd: enable LTO
authorStijn Tintel <stijn@linux-ipv6.be>
Mon, 5 Apr 2021 15:30:45 +0000 (18:30 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Mon, 5 Apr 2021 15:50:11 +0000 (18:50 +0300)
Size difference on mips_4kec:
W/o LTO: 139674
W/ LTO:  120196

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Suggested-by: Lucian Cristian <lucian.cristian@gmail.com>
package/network/services/lldpd/Makefile

index 5f5ff89740939e8e151f0f9668c4b0f1c44ba771..7b9bcccd4deaf7624d42d4ac6a48c7533d3e2f1c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
 PKG_VERSION:=1.0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://media.luffy.cx/files/lldpd
@@ -110,4 +110,7 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LLDPD_WITH_SNMP),--with-snmp,) \
        $(if $(CONFIG_USE_GLIBC),,--without-libbsd)
 
+TARGET_CFLAGS += -flto
+TARGET_LDFLAGS += -flto
+
 $(eval $(call BuildPackage,lldpd))