ath79: add support for devolo WiFi pro 1750c
authorDavid Bauer <mail@david-bauer.net>
Thu, 27 Dec 2018 01:32:39 +0000 (02:32 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 27 Dec 2018 13:06:38 +0000 (14:06 +0100)
Hardware
--------
CPU:   Qualcomm Atheros QCA9558
RAM:   128M DDR2
FLASH: 16MiB
ETH:   1x Atheros AR8035 (PoE in)
WiFi2: QCA9558 3T3R
WiFi5: QCA9880 3T3R
BTN:   1x Reset
LED:   1x LED blue
       1x LED red
BEEP:  1x GPIO attached piezo beeper
UART:  3.3V GND TX RX (115200-N-8) (3.3V is square pad)
       Header is located next to reset-button

There is also a Micro-B USB-port present but this only seems to be a
dummy as the circuit next to it is not present (at least in my unit).

It is also not mentioned in the devolo manual.

Installation
------------
Make sure you set a password for the root user as prompted on first
setup!

1. Upload OpenWRT sysupgrade image via SSH to the device.
Use /tmp as the destination folder on the device.
User is root, password the one set in the web interface.

2. Install OpenWRT with

> sysupgrade -n -F /tmp/<openwrt-image-name>

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9558_devolo_dvl1750c.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index b2c7762bb56154cf1ea1401c86716cf8103a39a6..64067c8da723de3ac48f1788113dc288ad71f662 100755 (executable)
@@ -10,6 +10,7 @@ ath79_setup_interfaces()
 
        case "$board" in
        avm,fritz300e|\
 
        case "$board" in
        avm,fritz300e|\
+       devolo,dvl1750c|\
        ocedo,koala|\
        ocedo,raccoon|\
        pcs,cap324|\
        ocedo,koala|\
        ocedo,raccoon|\
        pcs,cap324|\
index deaac721740ec5314732815f15df9955c76a79e6..b83f3c0b94d539ba68068a7b7ec14fcc3e33fc74 100644 (file)
@@ -87,7 +87,8 @@ board=$(board_name)
 case "$FIRMWARE" in
 "ath10k/cal-pci-0000:00:00.0.bin")
        case $board in
 case "$FIRMWARE" in
 "ath10k/cal-pci-0000:00:00.0.bin")
        case $board in
-       devolo,dvl1200e)
+       devolo,dvl1200e|\
+       devolo,dvl1750c)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac_crc $(macaddr_add $(mtd_get_mac_binary art 0) -1)
                ;;
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac_crc $(macaddr_add $(mtd_get_mac_binary art 0) -1)
                ;;
diff --git a/target/linux/ath79/dts/qca9558_devolo_dvl1750c.dts b/target/linux/ath79/dts/qca9558_devolo_dvl1750c.dts
new file mode 100644 (file)
index 0000000..b5a2954
--- /dev/null
@@ -0,0 +1,46 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9558_devolo_dvl1xxx.dtsi"
+
+/ {
+       compatible = "devolo,dvl1750c", "qca,qca9557";
+       model = "devolo WiFi pro 1750c";
+
+       aliases {
+               led-boot = &status_blue;
+               led-failsafe = &status_red;
+               led-running = &status_blue;
+               led-upgrade = &status_red;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               status_blue: status_blue {
+                       label = "dvl1750c:blue:status";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               status_red: status_red {
+                       label = "dvl1750c:red:status";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       beeper {
+               compatible = "gpio-beeper";
+               gpios = <&gpio 21 GPIO_ACTIVE_HIGH>;
+       };
+};
+
+&gmac_config {
+       rxdv-delay = <3>;
+       rxd-delay = <3>;
+       txen-delay = <3>;
+       txd-delay = <3>;
+};
index ef8cf170dea1d4b3477082c82d32d996aff91291..b2f83ba58c0b26d82638e607f6c64adcfb77b0b1 100644 (file)
@@ -146,6 +146,14 @@ define Device/devolo_dvl1200e
 endef
 TARGET_DEVICES += devolo_dvl1200e
 
 endef
 TARGET_DEVICES += devolo_dvl1200e
 
+define Device/devolo_dvl1750c
+  ATH_SOC := qca9558
+  DEVICE_TITLE := devolo WiFi pro 1750c
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1750c
+
 define Device/dlink_dir-825-b1
   ATH_SOC := ar7161
   DEVICE_TITLE := D-LINK DIR-825 B1
 define Device/dlink_dir-825-b1
   ATH_SOC := ar7161
   DEVICE_TITLE := D-LINK DIR-825 B1