opkg: drop argument from check_signature in opkg.conf
authorJonas Gorski <jonas.gorski@gmail.com>
Mon, 10 Sep 2018 09:42:53 +0000 (11:42 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 22 Jan 2019 12:14:14 +0000 (13:14 +0100)
check_signature is a bool option and doesn't take any arguments. The
presence of the 1 falsely suggests setting it to 0 disables the check,
while the option actually needs to be removed or commented out to be
disabled. So remove the argument to make it more clear.

Fixes: beca028bd6bb ("build: add integration for managing opkg package feed keys")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
(cherry picked from commit d3bf5ff9bc7b55b2a3dab93853b33a0cd2c4ca47)

package/system/opkg/Makefile

index f00e574de08d0f22d12b03895341c41f2a020933..67105675e8d0d6b307db6f035b9a81cd5d68438f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=opkg
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_FLAGS:=essential
 
 PKG_SOURCE_PROTO:=git
@@ -89,7 +89,7 @@ define Package/opkg/install
        $(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
   ifneq ($(CONFIG_SIGNED_PACKAGES),)
-       echo "option check_signature 1" >> $(1)/etc/opkg.conf
+       echo "option check_signature" >> $(1)/etc/opkg.conf
   endif
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/