kernel: bump 5.4 to 5.4.97
authorJohn Audia <graysky@archlinux.us>
Wed, 10 Feb 2021 16:20:24 +0000 (11:20 -0500)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 11 Feb 2021 15:08:28 +0000 (16:08 +0100)
Ran update_kernel.sh in a fresh clone without any existing toolchains.

Manually rebased:
 bcm27xx
  950-0267-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch
 bcm53xx
  180-usb-xhci-add-support-for-performing-fake-doorbell.patch
 layerscape
  302-dts-0008-arm64-dts-ls1046a-accumulated-change-to-ls1046a-boar.patch
  820-usb-0016-MLK-16735-usb-host-add-XHCI_CDNS_HOST-flag.patch
  820-usb-0018-MLK-18794-1-usb-host-xhci-add-.bus_suspend-override.patch

Build system: x86_64
Build-tested: bcm27xx/bcm2711, ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions/everything functional.

Signed-off-by: John Audia <graysky@archlinux.us>
[remove quilt comment, fix/adjust 820-usb-* layerscape patches]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
16 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-5.4/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm27xx/patches-5.4/950-0267-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch
target/linux/bcm27xx/patches-5.4/950-0316-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch
target/linux/bcm27xx/patches-5.4/950-0460-Kbuild-Allow-.dtbo-overlays-to-be-built-adjust.patch
target/linux/bcm53xx/patches-5.4/180-usb-xhci-add-support-for-performing-fake-doorbell.patch
target/linux/generic/backport-5.4/746-v5.5-net-dsa-mv88e6xxx-Split-monitor-port-configuration.patch
target/linux/generic/backport-5.4/747-v5.5-net-dsa-mv88e6xxx-Add-support-for-port-mirroring.patch
target/linux/generic/backport-5.4/748-v5.5-net-dsa-mv88e6xxx-fix-broken-if-statement-because-of.patch
target/linux/generic/pending-5.4/760-net-dsa-mv88e6xxx-fix-vlan-setup.patch
target/linux/layerscape/patches-5.4/302-dts-0008-arm64-dts-ls1046a-accumulated-change-to-ls1046a-boar.patch
target/linux/layerscape/patches-5.4/820-usb-0015-MLK-17380-4-usb-host-xhci-add-EH-SINGLE_STEP_SET_FEA.patch
target/linux/layerscape/patches-5.4/820-usb-0016-MLK-16735-usb-host-add-XHCI_CDNS_HOST-flag.patch
target/linux/layerscape/patches-5.4/820-usb-0017-MLK-19153-2-usb-host-xhci-do-not-return-error-status.patch
target/linux/layerscape/patches-5.4/820-usb-0018-MLK-18794-1-usb-host-xhci-add-.bus_suspend-override.patch
target/linux/layerscape/patches-5.4/820-usb-0020-MLK-16604-1-usb-host-xhci-plat-add-XHCI_MISSING_CAS-.patch

index 5d05c3c5acd67ed8fe26e9d27e212d18ab809d75..c9f92f9920b3dc132f3ba4f685a9d0ecf0d94fc7 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .96
+LINUX_VERSION-5.4 = .97
 
 
-LINUX_KERNEL_HASH-5.4.96 = f728de695ec5eb17efa15acaecc48fcd7a6c4a912b51704ed137cccf93f9f5e0
+LINUX_KERNEL_HASH-5.4.97 = 71a866100a630fbc66d24770f932feb121dd764c0bb95a88c0a00e3cb629483f
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 53f4aae7f1fbb76c4e8f162bf4a4ab4b17f21e70..40d731b8e68a892dc8af13cc26f6e54bf5b9cc87 100644 (file)
@@ -43,7 +43,7 @@ produce a noisy warning.
                hcd->msi_enabled = 1;
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
                hcd->msi_enabled = 1;
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1881,6 +1881,7 @@ struct xhci_hcd {
+@@ -1882,6 +1882,7 @@ struct xhci_hcd {
        struct xhci_hub         usb2_rhub;
        struct xhci_hub         usb3_rhub;
        /* support xHCI 1.0 spec USB2 hardware LPM */
        struct xhci_hub         usb2_rhub;
        struct xhci_hub         usb3_rhub;
        /* support xHCI 1.0 spec USB2 hardware LPM */
index e3c7c3038926c199d149fe4cfc080330364f16a6..a125fdcb475a49d8bc803857030fbeec3db5ff67 100644 (file)
@@ -85,6 +85,6 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
 +#define XHCI_EP_CTX_BROKEN_DCS        BIT_ULL(36)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
 +#define XHCI_EP_CTX_BROKEN_DCS        BIT_ULL(36)
+ #define XHCI_SKIP_PHY_INIT    BIT_ULL(37)
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  
-       unsigned int            num_active_eps;
index 0fb5c12ac34031b28cb90cd69c6e43e077d48846..d36f3eb80275bea1c27643856505f97ea3b17765 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/Makefile
 +++ b/Makefile
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1267,6 +1267,9 @@ ifneq ($(dtstree),)
+@@ -1261,6 +1261,9 @@ ifneq ($(dtstree),)
  %.dtb: include/config/kernel.release scripts_dtc
        $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
  
  %.dtb: include/config/kernel.release scripts_dtc
        $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
  
index a33cfe7142804e371eed776b78993b8c1917e624..b1cd7bffbeade2c3a1e4b727f73d9842bf0c65dd 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Nataliya Korovkina <malus.brandywine@gmail.com>
 
 --- a/Makefile
 +++ b/Makefile
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1267,7 +1267,7 @@ ifneq ($(dtstree),)
+@@ -1261,7 +1261,7 @@ ifneq ($(dtstree),)
  %.dtb: include/config/kernel.release scripts_dtc
        $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
  
  %.dtb: include/config/kernel.release scripts_dtc
        $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
  
index b27cbcad9f9f9be76fbbd16f55e37d7cd1489ed1..c160c6bf17fd2c8aabc6c79821a9844bf51491e8 100644 (file)
@@ -19,7 +19,7 @@ it on BCM4708 family.
 
 --- a/drivers/usb/host/xhci-plat.c
 +++ b/drivers/usb/host/xhci-plat.c
 
 --- a/drivers/usb/host/xhci-plat.c
 +++ b/drivers/usb/host/xhci-plat.c
-@@ -67,6 +67,8 @@ static int xhci_priv_resume_quirk(struct
+@@ -77,6 +77,8 @@ static int xhci_priv_resume_quirk(struct
  static void xhci_plat_quirks(struct device *dev, struct xhci_hcd *xhci)
  {
        struct xhci_plat_priv *priv = xhci_to_priv(xhci);
  static void xhci_plat_quirks(struct device *dev, struct xhci_hcd *xhci)
  {
        struct xhci_plat_priv *priv = xhci_to_priv(xhci);
@@ -28,7 +28,7 @@ it on BCM4708 family.
  
        /*
         * As of now platform drivers don't provide MSI support so we ensure
  
        /*
         * As of now platform drivers don't provide MSI support so we ensure
-@@ -74,6 +76,9 @@ static void xhci_plat_quirks(struct devi
+@@ -84,6 +86,9 @@ static void xhci_plat_quirks(struct devi
         * dev struct in order to setup MSI
         */
        xhci->quirks |= XHCI_PLAT | priv->quirks;
         * dev struct in order to setup MSI
         */
        xhci->quirks |= XHCI_PLAT | priv->quirks;
@@ -132,6 +132,6 @@ it on BCM4708 family.
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
 +#define XHCI_FAKE_DOORBELL    BIT_ULL(36)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
 +#define XHCI_FAKE_DOORBELL    BIT_ULL(36)
+ #define XHCI_SKIP_PHY_INIT    BIT_ULL(37)
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  
-       unsigned int            num_active_eps;
index 21424a3e4d8fea76577a22e5cb9d4808328f316c..683178727c3f555a9da2e7108dbed79de12b9f8b 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -2380,7 +2380,14 @@ static int mv88e6xxx_setup_upstream_port
+@@ -2384,7 +2384,14 @@ static int mv88e6xxx_setup_upstream_port
  
                if (chip->info->ops->set_egress_port) {
                        err = chip->info->ops->set_egress_port(chip,
  
                if (chip->info->ops->set_egress_port) {
                        err = chip->info->ops->set_egress_port(chip,
index 30ff8aeab60f270838c5ffdd311d7f2747219d55..a23f45075f82158bff0cf7315ac5878aee3ce12b 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -4922,6 +4922,80 @@ static int mv88e6xxx_port_mdb_del(struct
+@@ -4926,6 +4926,80 @@ static int mv88e6xxx_port_mdb_del(struct
        return err;
  }
  
        return err;
  }
  
@@ -106,7 +106,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static int mv88e6xxx_port_egress_floods(struct dsa_switch *ds, int port,
                                         bool unicast, bool multicast)
  {
  static int mv88e6xxx_port_egress_floods(struct dsa_switch *ds, int port,
                                         bool unicast, bool multicast)
  {
-@@ -4976,6 +5050,8 @@ static const struct dsa_switch_ops mv88e
+@@ -4980,6 +5054,8 @@ static const struct dsa_switch_ops mv88e
        .port_mdb_prepare       = mv88e6xxx_port_mdb_prepare,
        .port_mdb_add           = mv88e6xxx_port_mdb_add,
        .port_mdb_del           = mv88e6xxx_port_mdb_del,
        .port_mdb_prepare       = mv88e6xxx_port_mdb_prepare,
        .port_mdb_add           = mv88e6xxx_port_mdb_add,
        .port_mdb_del           = mv88e6xxx_port_mdb_del,
index d8ec1240f7e07feb92055c036eecc3df822ed6a9..37e7a7f2a9ceec73724ce9d349750d39e7d8ea09 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -4989,7 +4989,7 @@ static void mv88e6xxx_port_mirror_del(st
+@@ -4993,7 +4993,7 @@ static void mv88e6xxx_port_mirror_del(st
                if (chip->info->ops->set_egress_port(chip,
                                                     direction,
                                                     dsa_upstream_port(ds,
                if (chip->info->ops->set_egress_port(chip,
                                                     direction,
                                                     dsa_upstream_port(ds,
index 22cf41a8a7c6634bcd987039621925c4bf1a5b64..a49b48f744a1bf7036f3a5a8ae7fd43318f701bf 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: DENG Qingfang <dqfext@gmail.com>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -2659,6 +2659,7 @@ static int mv88e6xxx_setup(struct dsa_sw
+@@ -2663,6 +2663,7 @@ static int mv88e6xxx_setup(struct dsa_sw
  
        chip->ds = ds;
        ds->slave_mii_bus = mv88e6xxx_default_mdio_bus(chip);
  
        chip->ds = ds;
        ds->slave_mii_bus = mv88e6xxx_default_mdio_bus(chip);
index ae46d592c71265b18061d51e74f5ab4874a06da5..5079a815c21fbc5413fe15c362fbe7d9c90c2cd2 100644 (file)
@@ -277,15 +277,6 @@ Date:   Fri May 5 17:53:27 2017 +0800
                compatible = "spansion,m25p80";
 --- a/arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi
                compatible = "spansion,m25p80";
 --- a/arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi
 +++ b/arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi
-@@ -304,7 +304,7 @@
-               dcfg: dcfg@1ee0000 {
-                       compatible = "fsl,ls1046a-dcfg", "syscon";
--                      reg = <0x0 0x1ee0000 0x0 0x10000>;
-+                      reg = <0x0 0x1ee0000 0x0 0x1000>;
-                       big-endian;
-               };
 @@ -376,7 +376,7 @@
                };
  
 @@ -376,7 +376,7 @@
                };
  
index 00706bc4194189a4c3ce259aaed9dc04a4892de1..8ec95a98550e355bb26f4e3ebf4a83fcd6fa6f7e 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
                        retval = xhci_enter_test_mode(xhci, test_mode, wIndex,
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
                        retval = xhci_enter_test_mode(xhci, test_mode, wIndex,
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -3582,6 +3582,129 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
+@@ -3591,6 +3591,129 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
        return 0;
  }
  
        return 0;
  }
  
@@ -184,7 +184,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  void xhci_init_driver(struct hc_driver *drv,
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
  void xhci_init_driver(struct hc_driver *drv,
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -2144,6 +2144,16 @@ int xhci_find_raw_port_number(struct usb
+@@ -2149,6 +2149,16 @@ int xhci_find_raw_port_number(struct usb
  struct xhci_hub *xhci_get_rhub(struct usb_hcd *hcd);
  
  void xhci_hc_died(struct xhci_hcd *xhci);
  struct xhci_hub *xhci_get_rhub(struct usb_hcd *hcd);
  
  void xhci_hc_died(struct xhci_hcd *xhci);
index a934f289d85c996a3a0c9a24792932bbfdf08de6..6eb43e961e94ce91a02994d7ed7e46d5cd362e79 100644 (file)
@@ -37,6 +37,6 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
 +#define XHCI_CDNS_HOST                BIT_ULL(36)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
 +#define XHCI_CDNS_HOST                BIT_ULL(36)
+ #define XHCI_SKIP_PHY_INIT    BIT_ULL(37)
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  
-       unsigned int            num_active_eps;
index 90819594845ca3c9ede151fec2c0265598931e77..b08633eb883eaccf3120f3e66af2bd8031ecd129 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
 
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
 
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -2053,12 +2053,9 @@ static int process_ctrl_td(struct xhci_h
+@@ -2058,12 +2058,9 @@ static int process_ctrl_td(struct xhci_h
  
        switch (trb_comp_code) {
        case COMP_SUCCESS:
  
        switch (trb_comp_code) {
        case COMP_SUCCESS:
index c74b2460b443812027a0ca9d7b2078f6a1bd67c6..daef61c4d692d25df9b1d1e861a837632f977210 100644 (file)
@@ -24,10 +24,10 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -5381,6 +5381,8 @@ void xhci_init_driver(struct hc_driver *
-                       drv->reset = over->reset;
-               if (over->start)
-                       drv->start = over->start;
+@@ -5385,6 +5385,8 @@ void xhci_init_driver(struct hc_driver *
+                       drv->check_bandwidth = over->check_bandwidth;
+               if (over->reset_bandwidth)
+                       drv->reset_bandwidth = over->reset_bandwidth;
 +              if (over->bus_suspend)
 +                      drv->bus_suspend = over->bus_suspend;
        }
 +              if (over->bus_suspend)
 +                      drv->bus_suspend = over->bus_suspend;
        }
@@ -35,10 +35,10 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  EXPORT_SYMBOL_GPL(xhci_init_driver);
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
  EXPORT_SYMBOL_GPL(xhci_init_driver);
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1912,6 +1912,7 @@ struct xhci_driver_overrides {
-       size_t extra_priv_size;
-       int (*reset)(struct usb_hcd *hcd);
+@@ -1915,6 +1915,7 @@ struct xhci_driver_overrides {
        int (*start)(struct usb_hcd *hcd);
        int (*start)(struct usb_hcd *hcd);
+       int (*check_bandwidth)(struct usb_hcd *, struct usb_device *);
+       void (*reset_bandwidth)(struct usb_hcd *, struct usb_device *);
 +      int (*bus_suspend)(struct usb_hcd *hcd);
  };
  
 +      int (*bus_suspend)(struct usb_hcd *hcd);
  };
  
index ff150319ed6f9529f3ce05d30586afe7b7e03312..9fae877942a079c48f1d259b5fcd8d30e41caa15 100644 (file)
@@ -16,7 +16,7 @@ Acked-by: Peter Chen <peter.chen@nxp.com>
 
 --- a/drivers/usb/host/xhci-plat.c
 +++ b/drivers/usb/host/xhci-plat.c
 
 --- a/drivers/usb/host/xhci-plat.c
 +++ b/drivers/usb/host/xhci-plat.c
-@@ -291,6 +291,10 @@ static int xhci_plat_probe(struct platfo
+@@ -303,6 +303,10 @@ static int xhci_plat_probe(struct platfo
  
                device_property_read_u32(tmpdev, "imod-interval-ns",
                                         &xhci->imod_interval);
  
                device_property_read_u32(tmpdev, "imod-interval-ns",
                                         &xhci->imod_interval);