ath79: add support for TP-Link TL-WR710N v2.1
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 18 Aug 2020 11:49:15 +0000 (13:49 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 21 Aug 2020 09:34:55 +0000 (11:34 +0200)
This adds support for the TP-Link TL-WR710N v2.1. It is basically a
re-issue of the v1.2.

Specifications:

SoC:       Atheros AR9331
CPU:       400 MHz
Flash:     8 MiB
RAM:       32 MiB
WiFi:      2.4 GHz b/g/n
Ethernet:  2x 100M ports
USB:       1x 2.0

The only difference from the v1 is the TP-Link hardware ID/revision.

Attention:
The TL-WR710N v2.0 (!) has only 4 MB flash and cannot be flashed with
this image. It has a different TPLINK_HWREV, so accidental flashing
of the factory image should be impossible without additional measures.

Unfortunately, the v2.0 in ar71xx has the same board name, so sysupgrade
from ar71xx v2.0 into ath79 v1/v2.1 will not be prevented, but will brick
the device.

Flashing instruction:

Upload the factory image via the OEM firmware GUI upgrade mechanism.

Further notes:

To make implementation easier if somebody desires to port the 4M v2.0,
this already creates two DTSI files.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Tested-by: Fabian Eppig <fabian@eppig.de>
target/linux/ath79/dts/ar9331_tplink_tl-wr710n-8m.dtsi [new file with mode: 0644]
target/linux/ath79/dts/ar9331_tplink_tl-wr710n-v1.dts
target/linux/ath79/dts/ar9331_tplink_tl-wr710n-v2.1.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9331_tplink_tl-wr710n.dtsi [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk

diff --git a/target/linux/ath79/dts/ar9331_tplink_tl-wr710n-8m.dtsi b/target/linux/ath79/dts/ar9331_tplink_tl-wr710n-8m.dtsi
new file mode 100644 (file)
index 0000000..ffc98e6
--- /dev/null
@@ -0,0 +1,39 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9331_tplink_tl-wr710n.dtsi"
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               reg = <0x0 0x20000>;
+                               label = "u-boot";
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               compatible = "tplink,firmware";
+                               reg = <0x20000 0x7d0000>;
+                               label = "firmware";
+                       };
+
+                       art: partition@7f0000 {
+                               reg = <0x7f0000 0x10000>;
+                               label = "art";
+                               read-only;
+                       };
+               };
+       };
+};
index 493dbfe7b64193516bcaa5cc1774a54fcea27729..634b56d3be9a6eacbf8f901301828b13192e0620 100644 (file)
@@ -1,125 +1,9 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 /dts-v1/;
 
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9331.dtsi"
+#include "ar9331_tplink_tl-wr710n-8m.dtsi"
 
 / {
        model = "TP-Link TL-WR710N v1";
        compatible = "tplink,tl-wr710n-v1", "qca,ar9331";
-
-       aliases {
-               serial0 = &uart;
-               led-boot = &led_system;
-               led-failsafe = &led_system;
-               led-running = &led_system;
-               led-upgrade = &led_system;
-               label-mac-device = &eth0;
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_system: system {
-                       label = "tl-wr710n:green:system";
-                       gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       reg_usb_vbus: regulator {
-               compatible = "regulator-fixed";
-               regulator-name = "usb_vbus";
-               regulator-min-microvolt = <5000000>;
-               regulator-max-microvolt = <5000000>;
-               gpio = <&gpio 8 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-       };
-};
-
-&spi {
-       status = "okay";
-       num-cs = <1>;
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       uboot: partition@0 {
-                               reg = <0x0 0x20000>;
-                               label = "u-boot";
-                               read-only;
-                       };
-
-                       firmware: partition@20000 {
-                               compatible = "tplink,firmware";
-                               reg = <0x20000 0x7d0000>;
-                               label = "firmware";
-                       };
-
-                       art: partition@7f0000 {
-                               reg = <0x7f0000 0x10000>;
-                               label = "art";
-                               read-only;
-                       };
-               };
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       mtd-mac-address = <&uboot 0x1fc00>;
-
-       gmac-config {
-               device = <&gmac>;
-
-               switch-phy-addr-swap = <0>;
-               switch-phy-swap = <0>;
-       };
-};
-
-&eth1 {
-       status = "okay";
-
-       mtd-mac-address = <&uboot 0x1fc00>;
-       mtd-mac-address-increment = <(-1)>;
-};
-
-&uart {
-       status = "okay";
-};
-
-&usb {
-       dr_mode = "host";
-       vbus-supply = <&reg_usb_vbus>;
-       status = "okay";
-};
-
-&usb_phy {
-       status = "okay";
-};
-
-&wmac {
-       status = "okay";
-       mtd-cal-data = <&art 0x1000>;
-       mtd-mac-address = <&uboot 0x1fc00>;
 };
diff --git a/target/linux/ath79/dts/ar9331_tplink_tl-wr710n-v2.1.dts b/target/linux/ath79/dts/ar9331_tplink_tl-wr710n-v2.1.dts
new file mode 100644 (file)
index 0000000..48d4400
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9331_tplink_tl-wr710n-8m.dtsi"
+
+/ {
+       model = "TP-Link TL-WR710N v2.1";
+       compatible = "tplink,tl-wr710n-v2.1", "qca,ar9331";
+};
diff --git a/target/linux/ath79/dts/ar9331_tplink_tl-wr710n.dtsi b/target/linux/ath79/dts/ar9331_tplink_tl-wr710n.dtsi
new file mode 100644 (file)
index 0000000..e37c43f
--- /dev/null
@@ -0,0 +1,88 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9331.dtsi"
+
+/ {
+       aliases {
+               serial0 = &uart;
+               led-boot = &led_system;
+               led-failsafe = &led_system;
+               led-running = &led_system;
+               led-upgrade = &led_system;
+               label-mac-device = &eth0;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_system: system {
+                       label = "tl-wr710n:green:system";
+                       gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       reg_usb_vbus: regulator {
+               compatible = "regulator-fixed";
+               regulator-name = "usb_vbus";
+               regulator-min-microvolt = <5000000>;
+               regulator-max-microvolt = <5000000>;
+               gpio = <&gpio 8 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+
+       gmac-config {
+               device = <&gmac>;
+
+               switch-phy-addr-swap = <0>;
+               switch-phy-swap = <0>;
+       };
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <(-1)>;
+};
+
+&uart {
+       status = "okay";
+};
+
+&usb {
+       status = "okay";
+
+       dr_mode = "host";
+       vbus-supply = <&reg_usb_vbus>;
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&uboot 0x1fc00>;
+};
index fdc94b738a833a5bef281ae2e4021bf7164ea5c1..7128d853f8731a919d0023fdedaf4ad4c462c4a0 100644 (file)
@@ -625,6 +625,18 @@ define Device/tplink_tl-wr710n-v1
 endef
 TARGET_DEVICES += tplink_tl-wr710n-v1
 
+define Device/tplink_tl-wr710n-v2.1
+  $(Device/tplink-8mlzma)
+  SOC := ar9331
+  DEVICE_MODEL := TL-WR710N
+  DEVICE_VARIANT := v2.1
+  DEVICE_PACKAGES := kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
+  TPLINK_HWID := 0x07100002
+  TPLINK_HWREV := 0x2
+  SUPPORTED_DEVICES += tl-wr710n
+endef
+TARGET_DEVICES += tplink_tl-wr710n-v2.1
+
 define Device/tplink_tl-wr810n-v1
   $(Device/tplink-8mlzma)
   SOC := qca9531