add drivers-clean target when missing, use in-package module loading instead of ...
authorNicolas Thill <nico@openwrt.org>
Wed, 2 Nov 2005 22:44:54 +0000 (22:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 2 Nov 2005 22:44:54 +0000 (22:44 +0000)
SVN-Revision: 2317

openwrt/target/linux/linux-2.4/ar7.mk
openwrt/target/linux/linux-2.4/broadcom.mk
openwrt/target/linux/linux-2.4/config/ar7.modules [deleted file]
openwrt/target/linux/linux-2.4/config/brcm.modules [deleted file]
openwrt/target/linux/linux-2.4/config/x86.modules [deleted file]
openwrt/target/linux/linux-2.6/config/brcm.modules [deleted file]

index 8fd797bf460c1e7ad289c475b4719f7fae05e85b..85d5a790317e3b16d272c5883ee166c874b8d7ed 100644 (file)
@@ -23,6 +23,11 @@ $(LINUX_DIR)/.drivers-unpacked: $(LINUX_DIR)/.unpacked
        zcat $(DL_DIR)/$(ATM_FIRMWARE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        touch $@
 
+linux-dirclean: drivers-clean
+
+drivers-clean:
+       rm -rf $(BUILD_DIR)/$(ATM_FIRMWARE_DIR)
+
 
 $(eval $(call KMOD_template,SANGAM_ATM_A,sangam-atm-annex-a,\
        $(MODULES_DIR)/kernel/drivers/atm/tiatm.o \
@@ -37,6 +42,6 @@ $(eval $(call KMOD_template,SANGAM_ATM_B,sangam-atm-annex-b,\
 ))
 
 $(eval $(call KMOD_template,CPMAC,cpmac,\
-        $(MODULES_DIR)/kernel/drivers/net/avalanche_cpmac/avalanche_cpmac.o \
-,CONFIG_MIPS_AVALANCHE_CPMAC))
+       $(MODULES_DIR)/kernel/drivers/net/avalanche_cpmac/avalanche_cpmac.o \
+,CONFIG_MIPS_AVALANCHE_CPMAC),,10,avalanche_cpmac)
 
index 8419c5e854fe935b42befb9e6653b4446154f590..3cf8bd70ae144a719cc7ad00ca5fcc3c735aedef 100644 (file)
@@ -6,12 +6,15 @@
 #############################################################
 
 # broadcom specific kmod packages
+
 $(eval $(call KMOD_template,BRCM_WL,brcm-wl,\
        $(MODULES_DIR)/kernel/drivers/net/wl/wl.o \
-,CONFIG_WL))
+,CONFIG_WL),,10,wl)
+
 $(eval $(call KMOD_template,BRCM_ET,brcm-et,\
        $(MODULES_DIR)/kernel/drivers/net/et/et.o \
-,CONFIG_ET))
+,CONFIG_ET),,10,et)
+
 $(eval $(call KMOD_template,LP,lp,\
        $(MODULES_DIR)/kernel/drivers/parport/parport.o \
        $(MODULES_DIR)/kernel/drivers/parport/parport_splink.o \
diff --git a/openwrt/target/linux/linux-2.4/config/ar7.modules b/openwrt/target/linux/linux-2.4/config/ar7.modules
deleted file mode 100644 (file)
index 05eed86..0000000
+++ /dev/null
@@ -1 +0,0 @@
-avalanche_cpmac
diff --git a/openwrt/target/linux/linux-2.4/config/brcm.modules b/openwrt/target/linux/linux-2.4/config/brcm.modules
deleted file mode 100644 (file)
index e717eae..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-et
-wl
diff --git a/openwrt/target/linux/linux-2.4/config/x86.modules b/openwrt/target/linux/linux-2.4/config/x86.modules
deleted file mode 100644 (file)
index 8b13789..0000000
+++ /dev/null
@@ -1 +0,0 @@
-
diff --git a/openwrt/target/linux/linux-2.6/config/brcm.modules b/openwrt/target/linux/linux-2.6/config/brcm.modules
deleted file mode 100644 (file)
index b9fcff4..0000000
+++ /dev/null
@@ -1 +0,0 @@
-b44