kernel: fix dependency to xor-neon.ko
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 May 2014 22:56:33 +0000 (22:56 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 May 2014 22:56:33 +0000 (22:56 +0000)
If this module gets build the xor module depends on it

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 40666

package/kernel/linux/modules/lib.mk

index af536270f60380db3b75302107ebf39baa412c52..cd919ba62e9f6844bc0d45b7308b856a17d0f6f9 100644 (file)
@@ -138,8 +138,15 @@ define KernelPackage/lib-xor
   TITLE:=XOR blocks algorithm support
   HIDDEN:=1
   KCONFIG:=CONFIG_XOR_BLOCKS
+ifneq ($(wildcard $(LINUX_DIR)/arch/arm/lib/xor-neon.ko),)
+  FILES:= \
+    $(LINUX_DIR)/crypto/xor.ko \
+    $(LINUX_DIR)/arch/arm/lib/xor-neon.ko
+  AUTOLOAD:=$(call AutoProbe,xor-neon xor)
+else
   FILES:=$(LINUX_DIR)/crypto/xor.ko
   AUTOLOAD:=$(call AutoProbe,xor)
+endif
 endef
 
 define KernelPackage/lib-xor/description