ar71xx: Kernel board definition for PowerCloud CR3000
authorFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:27:25 +0000 (11:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:27:25 +0000 (11:27 +0000)
   Kernel part of support for PowerCloud CR3000.  The CR3000 is
    a 802.11n 2.4 GHz wireless router with 8MB flash, 64MB RAM,
    a four port fast ethernet switch, and a fast ethernet wan port which
    was sold by PowerCloud Systems as hardware for the Skydog
    cloud-managed router service.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
SVN-Revision: 47939

target/linux/ar71xx/config-4.1
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-cr3000.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/mikrotik/config-default
target/linux/ar71xx/nand/config-default

index e9b0053cfe12a16ec450237e476b467ea5d2ead5..25c5ad532c1e257efaae5aa6ab6b84bb52ff08b4 100644 (file)
@@ -55,6 +55,7 @@ CONFIG_ATH79_MACH_CAP4200AG=y
 CONFIG_ATH79_MACH_CARAMBOLA2=y
 CONFIG_ATH79_MACH_CF_E316N_V2=y
 CONFIG_ATH79_MACH_CPE510=y
+CONFIG_ATH79_MACH_CR3000=y
 CONFIG_ATH79_MACH_DB120=y
 CONFIG_ATH79_MACH_DGL_5500_A1=y
 CONFIG_ATH79_MACH_DHP_1565_A1=y
index 0d2d793633ade742c8e971f2ddb065361b7f2335..815c0ebae9b157542e2e43def97d4f9a430974cb 100644 (file)
@@ -923,6 +923,16 @@ config ATH79_MACH_CAP4200AG
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_CR3000
+       bool "PowerCloud CR3000 support"
+       select SOC_AR934X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_MR1750
        bool "OpenMesh MR1750 board support"
        select SOC_QCA955X
index e2cbacdc2207c737e1107c9fd454f79d935f2140..082828f60ec1a4c7862fb6f6c3c1da108bbf2356 100644 (file)
@@ -63,6 +63,7 @@ obj-$(CONFIG_ATH79_MACH_CAP324)               += mach-cap324.o
 obj-$(CONFIG_ATH79_MACH_CAP4200AG)     += mach-cap4200ag.o
 obj-$(CONFIG_ATH79_MACH_CF_E316N_V2)   += mach-cf-e316n-v2.o
 obj-$(CONFIG_ATH79_MACH_CPE510)                += mach-cpe510.o
+obj-$(CONFIG_ATH79_MACH_CR3000)                += mach-cr3000.o
 obj-$(CONFIG_ATH79_MACH_DB120)         += mach-db120.o
 obj-$(CONFIG_ATH79_MACH_DLAN_HOTSPOT)  += mach-dlan-hotspot.o
 obj-$(CONFIG_ATH79_MACH_DLAN_PRO_500_WP)       += mach-dlan-pro-500-wp.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-cr3000.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-cr3000.c
new file mode 100644 (file)
index 0000000..b351ae5
--- /dev/null
@@ -0,0 +1,161 @@
+/*
+ * PowerCloud Systems CR3000 support
+ *
+ * Copyright (c) 2011 Qualcomm Atheros
+ * Copyright (c) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (c) 2012-2013 PowerCloud Systems
+ * Copyright (c) 2015 Daniel Dickinson <openwrt@daniel.thecshore.com>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/gpio.h>
+#include <linux/pci.h>
+#include <linux/phy.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+#include <asm/mach-ath79/ath79.h>
+
+#include "common.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define CR3000_GPIO_LED_WLAN_2G                13
+#define CR3000_GPIO_LED_POWER_AMBER    15
+#define CR3000_GPIO_LED_WAN             18
+#define CR3000_GPIO_LED_LAN1            19
+#define CR3000_GPIO_LED_LAN2            20
+#define CR3000_GPIO_LED_LAN3            21
+#define CR3000_GPIO_LED_LAN4            22
+
+#define CR3000_GPIO_BTN_WPS            16
+#define CR3000_GPIO_BTN_RESET          17
+
+#define CR3000_KEYS_POLL_INTERVAL      20      /* msecs */
+#define CR3000_KEYS_DEBOUNCE_INTERVAL  (3 * CR3000_KEYS_POLL_INTERVAL)
+
+#define CR3000_MAC0_OFFSET             0
+#define CR3000_MAC1_OFFSET             6
+#define CR3000_WMAC_CALDATA_OFFSET     0x1000
+#define CR3000_WMAC_MAC_OFFSET         0x1002
+#define CR3000_PCIE_CALDATA_OFFSET     0x5000
+
+static struct gpio_led cr3000_leds_gpio[] __initdata = {
+       {
+               .name           = "pcs:amber:power",
+               .gpio           = CR3000_GPIO_LED_POWER_AMBER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "pcs:blue:wlan",
+               .gpio           = CR3000_GPIO_LED_WLAN_2G,
+               .active_low     = 1,
+       },
+       {
+               .name           = "pcs:blue:wan",
+               .gpio           = CR3000_GPIO_LED_WAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "pcs:blue:lan1",
+               .gpio           = CR3000_GPIO_LED_LAN1,
+               .active_low     = 1,
+       },
+       {
+               .name           = "pcs:blue:lan2",
+               .gpio           = CR3000_GPIO_LED_LAN2,
+               .active_low     = 1,
+       },
+       {
+               .name           = "pcs:blue:lan3",
+               .gpio           = CR3000_GPIO_LED_LAN3,
+               .active_low     = 1,
+       },
+       {
+               .name           = "pcs:blue:lan4",
+               .gpio           = CR3000_GPIO_LED_LAN4,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button cr3000_gpio_keys[] __initdata = {
+       {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = CR3000_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = CR3000_GPIO_BTN_WPS,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = CR3000_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = CR3000_GPIO_BTN_RESET,
+               .active_low     = 1,
+       },
+};
+
+static void __init cr3000_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(cr3000_leds_gpio),
+                                cr3000_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, CR3000_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(cr3000_gpio_keys),
+                                       cr3000_gpio_keys);
+
+       /* WLAN 2GHz onboard */
+       ath79_register_wmac(art + CR3000_WMAC_CALDATA_OFFSET, art + CR3000_WMAC_MAC_OFFSET);
+       
+       ath79_register_mdio(1, 0x0);
+       ath79_register_mdio(0, 0x0);
+
+       ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_SW_PHY_SWAP);
+
+       /* Lan 4-port switch attached to GMAC1 internal switch */
+       ath79_init_mac(ath79_eth1_data.mac_addr, art + CR3000_MAC0_OFFSET, 0);
+
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+       ath79_register_eth(1);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, art + CR3000_MAC1_OFFSET, 0);
+
+       /* WAN Fast Ethernet interface attached to GMAC0 */
+       ath79_switch_data.phy4_mii_en = 1;
+       ath79_switch_data.phy_poll_mask = BIT(0);
+       ath79_eth0_data.phy_mask = BIT(0);
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio1_device.dev;
+       ath79_register_eth(0);
+}
+
+MIPS_MACHINE(ATH79_MACH_CR3000, "CR3000", "PowerCloud CR3000",
+            cr3000_setup);
index f5f7ab551bb215b5a88fd8d81b6a7aaac50313cf..010e4b3d56c315bb698485b1baa16c9e2b2b8929 100644 (file)
@@ -47,6 +47,7 @@ enum ath79_mach_type {
        ATH79_MACH_CARAMBOLA2,          /* 8devices Carambola2 */
        ATH79_MACH_CF_E316N_V2,         /* COMFAST CF-E316N v2 */
        ATH79_MACH_CPE510,              /* TP-LINK CPE510 */
+       ATH79_MACH_CR3000,              /* PowerCloud CR3000 */
        ATH79_MACH_DB120,               /* Atheros DB120 reference board */
        ATH79_MACH_PB44,                /* Atheros PB44 reference board */
        ATH79_MACH_DGL_5500_A1,         /* D-link DGL-5500 rev. A1 */
index c46529ce69097fca8a98319557ee322fe7608326..d541c0f0c042cfc9955c9f4588e960565966ba87 100644 (file)
@@ -19,6 +19,7 @@
 # CONFIG_ATH79_MACH_CAP4200AG is not set
 # CONFIG_ATH79_MACH_CARAMBOLA2 is not set
 # CONFIG_ATH79_MACH_CPE510 is not set
+# CONFIG_ATH79_MACH_CR3000 is not set
 # CONFIG_ATH79_MACH_DB120 is not set
 # CONFIG_ATH79_MACH_DGL_5500_A1 is not set
 # CONFIG_ATH79_MACH_DHP_1565_A1 is not set
index 0368ffd3fc0cafef64f390643b61cb72a6b4e17a..b85923baa007408a44132c97a4077d388680def5 100644 (file)
@@ -16,6 +16,7 @@
 # CONFIG_ATH79_MACH_CAP324 is not set
 # CONFIG_ATH79_MACH_CAP4200AG is not set
 # CONFIG_ATH79_MACH_CARAMBOLA2 is not set
+# CONFIG_ATH79_MACH_CR3000 is not set
 # CONFIG_ATH79_MACH_DB120 is not set
 # CONFIG_ATH79_MACH_DIR_505_A1 is not set
 # CONFIG_ATH79_MACH_DIR_600_A1 is not set