build: make testing kernel decompression more portable
authorFelix Fietkau <nbd@nbd.name>
Thu, 26 Nov 2020 15:12:12 +0000 (16:12 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sat, 5 Dec 2020 11:06:30 +0000 (12:06 +0100)
On non-GNU systems, zcat often does not handle gzip decompression.
Use gzip -dc like the regular unpack command

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/kernel-defaults.mk

index db93a53d71e42ebe2d3312ebcefceaa611fb1f72..863c180e48ae894e1fff2924ef3e54f45d26d394 100644 (file)
@@ -24,7 +24,7 @@ Kernel/Patch:=$(Kernel/Patch/Default)
 ifneq (,$(findstring .xz,$(LINUX_SOURCE)))
   LINUX_CAT:=xzcat
 else
-  LINUX_CAT:=zcat
+  LINUX_CAT:=gzip -dc
 endif
 
 ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")