apm821xx: derive DEVICE_DTS from device name
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 18 Jul 2020 11:14:28 +0000 (13:14 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 21 Jul 2020 09:56:35 +0000 (11:56 +0200)
The DEVICE_DTS variable always matches the device definition name,
just with "_" replaced by "-". Thus, create a DEVICE_DTS definition
in Device/Default and drop all the individual statements.

If necessary in the future, local DEVICE_DTS will still overwrite
that default.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/apm821xx/image/Makefile
target/linux/apm821xx/image/nand.mk
target/linux/apm821xx/image/sata.mk

index 1b7c466a44d359a38e330e6f119fb07674e285ad..2331947e332e5447aec9becf779bfd7f7c7b6975 100644 (file)
@@ -87,6 +87,7 @@ define Device/Default
   KERNEL_ENTRY := 0x00000000
   KERNEL_LOADADDR := 0x00000000
   DEVICE_DTS_DIR := ../dts
+  DEVICE_DTS = $(subst _,-,$(1))
   SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
 endef
 
index a7338e79a06b5e097814c70db0f120ba67cdeef4..29a4be0189846cc793face3e04688af20178a620 100644 (file)
@@ -29,7 +29,6 @@ define Device/meraki_mr24
   DEVICE_MODEL := MR24
   DEVICE_PACKAGES := kmod-spi-gpio -swconfig
   BOARD_NAME := mr24
-  DEVICE_DTS := meraki-mr24
   IMAGES := sysupgrade.bin
   DTB_SIZE := 64512
   IMAGE_SIZE := 8191k
@@ -47,7 +46,6 @@ define Device/meraki_mx60
   DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-ledtrig-usbport kmod-usb-dwc2 \
                     kmod-usb-storage block-mount
   BOARD_NAME := mx60
-  DEVICE_DTS := meraki-mx60
   BLOCKSIZE := 63k
   IMAGES := sysupgrade.bin
   DTB_SIZE := 64512
@@ -80,14 +78,12 @@ endef
 define Device/netgear_wndap620
   $(Device/netgear_wndap6x0)
   DEVICE_MODEL := WNDAP620 (Premium Wireless-N)
-  DEVICE_DTS := netgear-wndap620
 endef
 TARGET_DEVICES += netgear_wndap620
 
 define Device/netgear_wndap660
   $(Device/netgear_wndap6x0)
   DEVICE_MODEL := WNDAP660 (Dual Radio Dual Band Wireless-N)
-  DEVICE_DTS := netgear-wndap660
 endef
 TARGET_DEVICES += netgear_wndap660
 
@@ -100,7 +96,6 @@ define Device/netgear_wndr4700
        kmod-nls-utf8 kmod-usb3 kmod-usb-dwc2 kmod-usb-storage \
        partx-utils
   BOARD_NAME := wndr4700
-  DEVICE_DTS := netgear-wndr4700
   PAGESIZE := 2048
   SUBPAGESIZE := 512
   BLOCKSIZE := 128k
index 444b2441f01bebf62cef197c3288b22fd7be86f3..6fe8324b93aca3b0519619a57940780dc00a3007 100644 (file)
@@ -7,7 +7,6 @@ define Device/wd_mybooklive
   DEVICE_VENDOR := Western Digital
   DEVICE_MODEL := My Book Live Series (Single + Duo)
   DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic
-  DEVICE_DTS := wd-mybooklive
   SUPPORTED_DEVICES += mbl wd,mybooklive-duo
   BLOCKSIZE := 1k
   DTB_SIZE := 16384