ramips: fix Gigabit Ethernet port of the HiWiFi HC5861
authorShiji Yang <yangshiji66@qq.com>
Tue, 26 Sep 2023 12:12:45 +0000 (20:12 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 29 Oct 2023 21:49:35 +0000 (22:49 +0100)
HiWiFi HC5861 has a GbE port which connected to the RTL8211E PHY
chip. This patch adds the missing Realtek PHY driver package and
sets the correct external PHYs base address to make it work again.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
target/linux/ramips/dts/mt7620a_hiwifi_hc5861.dts
target/linux/ramips/image/mt7620.mk

index ef22a6639d4d4ca9ca058cc42c62903ac8f4678a..3f3ed3313f0fe3f313500dc76d899e21372c17d8 100644 (file)
@@ -70,7 +70,7 @@
 
 &ethernet {
        pinctrl-names = "default";
-       pinctrl-0 = <&rgmii1_pins &mdio_pins>;
+       pinctrl-0 = <&mdio_pins>, <&rgmii1_pins>;
 
        nvmem-cells = <&macaddr_factory_4>;
        nvmem-cell-names = "mac-address";
        };
 };
 
+&gsw {
+       mediatek,ephy-base = /bits/ 8 <12>;
+};
+
 &pcie {
        status = "okay";
 };
index f3f4873d769e29044e05f245b5c768b82dfece55..f85f3c8521e8604b6c8d2968d40e884362df340f 100644 (file)
@@ -578,7 +578,7 @@ define Device/hiwifi_hc5861
   DEVICE_VENDOR := HiWiFi
   DEVICE_MODEL := HC5861
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
-       kmod-usb-ledtrig-usbport
+       kmod-phy-realtek kmod-usb-ledtrig-usbport
   SUPPORTED_DEVICES += hc5861
 endef
 TARGET_DEVICES += hiwifi_hc5861