ar71xx: add profile for Allnet devices
authorGabor Juhos <juhosg@openwrt.org>
Mon, 27 Aug 2012 14:55:38 +0000 (14:55 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 27 Aug 2012 14:55:38 +0000 (14:55 +0000)
Signed-off-by: Daniel Golle <dgolle@allnet.de>
SVN-Revision: 33287

target/linux/ar71xx/generic/profiles/allnet.mk [new file with mode: 0644]

diff --git a/target/linux/ar71xx/generic/profiles/allnet.mk b/target/linux/ar71xx/generic/profiles/allnet.mk
new file mode 100644 (file)
index 0000000..986b633
--- /dev/null
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 20012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ALL0305
+       NAME:=Allnet ALL0305
+       PACKAGES:=fconfig kmod-ath5k -kmod-ath9k
+endef
+
+define Profile/ALL0305/Description
+       Package set optimized for the Allnet ALL0305.
+endef
+
+$(eval $(call Profile,ALL0305))
+
+define Profile/ALL0258N
+       NAME:=Allnet ALL0258N
+       PACKAGES:=uboot-envtools
+endef
+
+define Profile/ALL0258N/Description
+       Package set optimized for the Allnet ALL0258N.
+endef
+
+$(eval $(call Profile,ALL0258N))
+
+define Profile/ALL0315N
+       NAME:=Allnet ALL0315N
+       PACKAGES:=uboot-envtools
+endef
+
+define Profile/ALL0315N/Description
+       Package set optimized for the Allnet ALL0315N.
+endef
+
+$(eval $(call Profile,ALL0315N))