kernel: bump 5.4 to 5.4.142
authorJohn Audia <graysky@archlinux.us>
Wed, 18 Aug 2021 12:06:08 +0000 (08:06 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 21 Aug 2021 13:59:39 +0000 (15:59 +0200)
Removed upstreamed:
  hack-5.4/991-platform-x86-pcengines-apuv2-revert-simswitch.patch

All other patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
13 files changed:
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0445-dma-mapping-treat-dev-bus_dma_mask-as-a-DMA-limit.patch
target/linux/generic/backport-5.4/745-v5.7-net-dsa-mt7530-add-support-for-port-mirroring.patch
target/linux/generic/backport-5.4/753-v5.8-net-dsa-mt7530-fix-VLAN-setup.patch
target/linux/generic/backport-5.4/780-net-dsa-mt7530-setup-core-clock-even-in-TRGMII-mode.patch
target/linux/generic/hack-5.4/221-module_exports.patch
target/linux/generic/hack-5.4/991-platform-x86-pcengines-apuv2-revert-simswitch.patch [deleted file]
target/linux/generic/pending-5.4/761-net-dsa-mt7530-Support-EEE-features.patch
target/linux/mediatek/patches-5.4/0601-net-dsa-propagate-resolved-link-config-via-mac_link_.patch
target/linux/mediatek/patches-5.4/0602-net-dsa-mt7530-use-resolved-link-config-in-mac_link_.patch
target/linux/mediatek/patches-5.4/0603-net-dsa-mt7530-Extend-device-data-ready-for-adding-a.patch
target/linux/mediatek/patches-5.4/0604-net-dsa-mt7530-Add-the-support-of-MT7531-switch.patch
target/linux/x86/patches-5.4/012-pcengines-apu2-detect-apuv4-board.patch

index 4f15e91614e236b484fc7ca84f0af152d86d0e6e..6e7ad9d1a98088ebe072a1761cd788e0b07df343 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .141
+LINUX_VERSION-5.4 = .142
 LINUX_VERSION-5.10 = .60
 
-LINUX_KERNEL_HASH-5.4.141 = 10636d360cc5ba3857f8e91dfb0a4efcdb1406675e981fa9433748b097138c28
+LINUX_KERNEL_HASH-5.4.142 = 99785728968564ba27c7e552d024b560072dcbc885540912eabb5c021e231451
 LINUX_KERNEL_HASH-5.10.60 = 696ff7753f6c7c5123dbcb0a22d693cb358c760c61a76649531b6a207155f78d
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 344e1ee37efcf493dfa2356cb9fd5475a441ec8a..711d06fd51e54e8f4a9a8c1616c2c7aa7bbd674c 100644 (file)
@@ -249,7 +249,7 @@ Signed-off-by: Christoph Hellwig <hch@lst.de>
   * @dma_pfn_offset: offset of DMA memory range relatively of RAM
   * @dma_parms:        A low level driver may set these to teach IOMMU code about
   *            segment limitations.
-@@ -1270,7 +1270,7 @@ struct device {
+@@ -1271,7 +1271,7 @@ struct device {
                                             not all hardware supports
                                             64 bit addresses for consistent
                                             allocations such descriptors. */
index d4e6f8664de44eda7885ae383b19d0fb5ac0bdee..14bf827806344300ab93b82eb22f09ca83783206 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -1145,6 +1145,64 @@ mt7530_port_vlan_del(struct dsa_switch *
+@@ -1146,6 +1146,64 @@ mt7530_port_vlan_del(struct dsa_switch *
        return 0;
  }
  
@@ -82,7 +82,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static enum dsa_tag_protocol
  mtk_get_tag_protocol(struct dsa_switch *ds, int port)
  {
-@@ -1522,6 +1580,8 @@ static const struct dsa_switch_ops mt753
+@@ -1523,6 +1581,8 @@ static const struct dsa_switch_ops mt753
        .port_vlan_prepare      = mt7530_port_vlan_prepare,
        .port_vlan_add          = mt7530_port_vlan_add,
        .port_vlan_del          = mt7530_port_vlan_del,
index eea9bf28d1d15f308874b50df5ae0ec7039c1b83..98d213ee6ef7ce34dc7cc049bc6b634d2e8415d7 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -1085,12 +1085,6 @@ mt7530_port_vlan_add(struct dsa_switch *
+@@ -1086,12 +1086,6 @@ mt7530_port_vlan_add(struct dsa_switch *
        struct mt7530_priv *priv = ds->priv;
        u16 vid;
  
@@ -28,7 +28,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        mutex_lock(&priv->reg_mutex);
  
        for (vid = vlan->vid_begin; vid <= vlan->vid_end; ++vid) {
-@@ -1116,12 +1110,6 @@ mt7530_port_vlan_del(struct dsa_switch *
+@@ -1117,12 +1111,6 @@ mt7530_port_vlan_del(struct dsa_switch *
        struct mt7530_priv *priv = ds->priv;
        u16 vid, pvid;
  
@@ -41,7 +41,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        mutex_lock(&priv->reg_mutex);
  
        pvid = priv->ports[port].pvid;
-@@ -1234,6 +1222,7 @@ mt7530_setup(struct dsa_switch *ds)
+@@ -1235,6 +1223,7 @@ mt7530_setup(struct dsa_switch *ds)
         * as two netdev instances.
         */
        dn = ds->ports[MT7530_CPU_PORT].master->dev.of_node->parent;
index d48d7972942ff618a76889bf6a720dae5d2ef767..7ad7cd3a01ca283ef04846c3e4f872420294e320 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -427,34 +427,32 @@ mt7530_pad_clk_setup(struct dsa_switch *
+@@ -428,34 +428,32 @@ mt7530_pad_clk_setup(struct dsa_switch *
                             TD_DM_DRVP(8) | TD_DM_DRVN(8));
  
        /* Setup core clock for MT7530 */
index 0f7840b8d87e993bbeea1536cc5e2bb5eaff831e..47f40ac5e194a6247230c5ca326f1ed405cbd161 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -904,6 +914,8 @@
+@@ -905,6 +915,8 @@
        EXIT_TEXT                                                       \
        EXIT_DATA                                                       \
        EXIT_CALL                                                       \
diff --git a/target/linux/generic/hack-5.4/991-platform-x86-pcengines-apuv2-revert-simswitch.patch b/target/linux/generic/hack-5.4/991-platform-x86-pcengines-apuv2-revert-simswitch.patch
deleted file mode 100644 (file)
index 84a4191..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-From 8c9254d41881c81bea610193c6ac59c8cb8b79fe Mon Sep 17 00:00:00 2001
-From: Florian Eckert <fe@dev.tdt.de>
-Date: Fri, 27 Mar 2020 16:11:55 +0100
-Subject: [PATCH] Revert "platform/x86: pcengines-apuv2: wire up simswitch gpio
- as led"
-
-This reverts commit 5037d4ddda31c2dbbb018109655f61054b1756dc.
-
-Commit message from linux:
-The APU3+ boards have two SIM sockets, while only one of them
-can be routed to the mpcie slots at a time. Selection is done
-via simswap gpio.
-
-We currently don't have a fitting subsystem for those cases yet,
-so just wire it up to a LED for the time being. While this isn't
-really semantically correct, it's a good compromise.
-
-Explanation why this does not work:
-This change connects the simswap to the LED subsystem of the kernel.
-From my point of view, it's nonsense. If we do it this way, then this
-can be switched relatively easily via the LED subsystem (trigger:
-none/default-on) and that is dangerous! If this is used, it would be
-unfavorable, since there is also another trigger (trigger: heartbeat/netdev).
-This LED also appears in the LuCI and can therefore be switched by the user.
-
-Therefore, this simswap GPIO should remain in the GPIO
-subsystem and be switched via it and not be connected to the LED
-subsystem. To avoid the problems mentioned above. The LED subsystem is
-not made for this and it is not a good compromise, but rather dangerous.
-
-Signed-off-by: Florian Eckert <fe@dev.tdt.de>
----
- drivers/platform/x86/pcengines-apuv2.c | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
---- a/drivers/platform/x86/pcengines-apuv2.c
-+++ b/drivers/platform/x86/pcengines-apuv2.c
-@@ -77,8 +77,7 @@ static const struct amd_fch_gpio_pdata b
- static const struct gpio_led apu2_leds[] = {
-       { .name = "apu:green:1" },
-       { .name = "apu:green:2" },
--      { .name = "apu:green:3" },
--      { .name = "apu:simswap" },
-+      { .name = "apu:green:3" }
- };
- static const struct gpio_led_platform_data apu2_leds_pdata = {
-@@ -95,8 +94,6 @@ static struct gpiod_lookup_table gpios_l
-                               NULL, 1, GPIO_ACTIVE_LOW),
-               GPIO_LOOKUP_IDX(AMD_FCH_GPIO_DRIVER_NAME, APU2_GPIO_LINE_LED3,
-                               NULL, 2, GPIO_ACTIVE_LOW),
--              GPIO_LOOKUP_IDX(AMD_FCH_GPIO_DRIVER_NAME, APU2_GPIO_LINE_SIMSWAP,
--                              NULL, 3, GPIO_ACTIVE_LOW),
-       }
- };
index e8f35b6e1f6b6f1169ccb1a409751a52be95d61f..02b369955b32b3b354c19203a71430a860744dbd 100644 (file)
@@ -9,7 +9,7 @@ Content-Transfer-Encoding: 8bit
 Signed-off-by: René van Dorst <opensource@vdorst.com>
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -1409,9 +1409,13 @@ static void mt7530_phylink_mac_config(st
+@@ -1410,9 +1410,13 @@ static void mt7530_phylink_mac_config(st
        switch (state->speed) {
        case SPEED_1000:
                mcr_new |= PMCR_FORCE_SPEED_1000;
@@ -23,7 +23,7 @@ Signed-off-by: René van Dorst <opensource@vdorst.com>
                break;
        }
        if (state->duplex == DUPLEX_FULL) {
-@@ -1547,6 +1551,54 @@ mt7530_phylink_mac_link_state(struct dsa
+@@ -1548,6 +1552,54 @@ mt7530_phylink_mac_link_state(struct dsa
        return 1;
  }
  
@@ -78,7 +78,7 @@ Signed-off-by: René van Dorst <opensource@vdorst.com>
  static const struct dsa_switch_ops mt7530_switch_ops = {
        .get_tag_protocol       = mtk_get_tag_protocol,
        .setup                  = mt7530_setup,
-@@ -1574,6 +1626,8 @@ static const struct dsa_switch_ops mt753
+@@ -1575,6 +1627,8 @@ static const struct dsa_switch_ops mt753
        .phylink_mac_config     = mt7530_phylink_mac_config,
        .phylink_mac_link_down  = mt7530_phylink_mac_link_down,
        .phylink_mac_link_up    = mt7530_phylink_mac_link_up,
index 913784372b4cc7cc9774f61f4dc242c401200f5a..fe4f9855be5bb964fdee8ae701f410c754c30d93 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        struct ethtool_eee *p = &priv->dev->ports[port].eee;
 --- a/drivers/net/dsa/lantiq_gswip.c
 +++ b/drivers/net/dsa/lantiq_gswip.c
-@@ -1657,7 +1657,9 @@ static void gswip_phylink_mac_link_down(
+@@ -1663,7 +1663,9 @@ static void gswip_phylink_mac_link_down(
  static void gswip_phylink_mac_link_up(struct dsa_switch *ds, int port,
                                      unsigned int mode,
                                      phy_interface_t interface,
@@ -64,7 +64,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -1442,7 +1442,9 @@ static void mt7530_phylink_mac_link_down
+@@ -1443,7 +1443,9 @@ static void mt7530_phylink_mac_link_down
  static void mt7530_phylink_mac_link_up(struct dsa_switch *ds, int port,
                                       unsigned int mode,
                                       phy_interface_t interface,
index 0f437ae15332ffc946d3e263dad2ac6647f7fd6a..87235e6054783dcbfa65008e7991067222a9aeca 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -488,17 +488,6 @@ mt7530_mib_reset(struct dsa_switch *ds)
+@@ -489,17 +489,6 @@ mt7530_mib_reset(struct dsa_switch *ds)
        mt7530_write(priv, MT7530_MIB_CCR, CCR_MIB_ACTIVATE);
  }
  
@@ -33,7 +33,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static int mt7530_phy_read(struct dsa_switch *ds, int port, int regnum)
  {
        struct mt7530_priv *priv = ds->priv;
-@@ -672,7 +661,7 @@ mt7530_port_enable(struct dsa_switch *ds
+@@ -673,7 +662,7 @@ mt7530_port_enable(struct dsa_switch *ds
        priv->ports[port].enable = true;
        mt7530_rmw(priv, MT7530_PCR_P(port), PCR_MATRIX_MASK,
                   priv->ports[port].pm);
@@ -42,7 +42,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        mutex_unlock(&priv->reg_mutex);
  
-@@ -695,7 +684,7 @@ mt7530_port_disable(struct dsa_switch *d
+@@ -696,7 +685,7 @@ mt7530_port_disable(struct dsa_switch *d
        priv->ports[port].enable = false;
        mt7530_rmw(priv, MT7530_PCR_P(port), PCR_MATRIX_MASK,
                   PCR_MATRIX_CLR);
@@ -51,7 +51,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        mutex_unlock(&priv->reg_mutex);
  }
-@@ -1397,8 +1386,7 @@ static void mt7530_phylink_mac_config(st
+@@ -1398,8 +1387,7 @@ static void mt7530_phylink_mac_config(st
  
        mcr_cur = mt7530_read(priv, MT7530_PMCR_P(port));
        mcr_new = mcr_cur;
@@ -61,7 +61,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        mcr_new |= PMCR_IFG_XMIT(1) | PMCR_MAC_MODE | PMCR_BACKOFF_EN |
                   PMCR_BACKPR_EN | PMCR_FORCE_MODE;
  
-@@ -1406,26 +1394,6 @@ static void mt7530_phylink_mac_config(st
+@@ -1407,26 +1395,6 @@ static void mt7530_phylink_mac_config(st
        if (port == 5 && dsa_is_user_port(ds, 5))
                mcr_new |= PMCR_EXT_PHY;
  
@@ -88,7 +88,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (mcr_new != mcr_cur)
                mt7530_write(priv, MT7530_PMCR_P(port), mcr_new);
  }
-@@ -1436,7 +1404,7 @@ static void mt7530_phylink_mac_link_down
+@@ -1437,7 +1405,7 @@ static void mt7530_phylink_mac_link_down
  {
        struct mt7530_priv *priv = ds->priv;
  
@@ -97,7 +97,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  }
  
  static void mt7530_phylink_mac_link_up(struct dsa_switch *ds, int port,
-@@ -1447,8 +1415,31 @@ static void mt7530_phylink_mac_link_up(s
+@@ -1448,8 +1416,31 @@ static void mt7530_phylink_mac_link_up(s
                                       bool tx_pause, bool rx_pause)
  {
        struct mt7530_priv *priv = ds->priv;
index 9ac5599a254d3213c753ad4e435f4d5e63a297f2..291307791d5bbe0439c3acc4183ebfe6dd82c736 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -372,8 +372,9 @@ mt7530_fdb_write(struct mt7530_priv *pri
+@@ -373,8 +373,9 @@ mt7530_fdb_write(struct mt7530_priv *pri
                mt7530_write(priv, MT7530_ATA1 + (i * 4), reg[i]);
  }
  
@@ -28,7 +28,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  {
        struct mt7530_priv *priv = ds->priv;
        u32 ncpo1, ssc_delta, trgint, i, xtal;
-@@ -387,7 +388,7 @@ mt7530_pad_clk_setup(struct dsa_switch *
+@@ -388,7 +389,7 @@ mt7530_pad_clk_setup(struct dsa_switch *
                return -EINVAL;
        }
  
@@ -37,7 +37,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
        case PHY_INTERFACE_MODE_RGMII:
                trgint = 0;
                /* PLL frequency: 125MHz */
-@@ -409,7 +410,8 @@ mt7530_pad_clk_setup(struct dsa_switch *
+@@ -410,7 +411,8 @@ mt7530_pad_clk_setup(struct dsa_switch *
                }
                break;
        default:
@@ -47,7 +47,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                return -EINVAL;
        }
  
-@@ -1334,12 +1336,11 @@ mt7530_setup(struct dsa_switch *ds)
+@@ -1335,12 +1337,11 @@ mt7530_setup(struct dsa_switch *ds)
        return 0;
  }
  
@@ -63,7 +63,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  
        switch (port) {
        case 0: /* Internal phy */
-@@ -1348,33 +1349,114 @@ static void mt7530_phylink_mac_config(st
+@@ -1349,33 +1350,114 @@ static void mt7530_phylink_mac_config(st
        case 3:
        case 4:
                if (state->interface != PHY_INTERFACE_MODE_GMII)
@@ -189,7 +189,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                return;
        }
  
-@@ -1442,61 +1524,44 @@ static void mt7530_phylink_mac_link_up(s
+@@ -1443,61 +1525,44 @@ static void mt7530_phylink_mac_link_up(s
        mt7530_set(priv, MT7530_PMCR_P(port), mcr);
  }
  
@@ -274,7 +274,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
        phylink_set(mask, Pause);
        phylink_set(mask, Asym_Pause);
  
-@@ -1592,12 +1657,45 @@ static int mt7530_set_mac_eee(struct dsa
+@@ -1593,12 +1658,45 @@ static int mt7530_set_mac_eee(struct dsa
        return 0;
  }
  
@@ -323,7 +323,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
        .get_ethtool_stats      = mt7530_get_ethtool_stats,
        .get_sset_count         = mt7530_get_sset_count,
        .port_enable            = mt7530_port_enable,
-@@ -1614,18 +1712,43 @@ static const struct dsa_switch_ops mt753
+@@ -1615,18 +1713,43 @@ static const struct dsa_switch_ops mt753
        .port_vlan_del          = mt7530_port_vlan_del,
        .port_mirror_add        = mt7530_port_mirror_add,
        .port_mirror_del        = mt7530_port_mirror_del,
@@ -372,7 +372,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
        { /* sentinel */ },
  };
  MODULE_DEVICE_TABLE(of, mt7530_of_match);
-@@ -1663,8 +1786,21 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -1664,8 +1787,21 @@ mt7530_probe(struct mdio_device *mdiodev
        /* Get the hardware identifier from the devicetree node.
         * We will need it for some of the clock and regulator setup.
         */
index 8434c61b505391fc0024029e8009c72a357ed4f8..2d20bbc37c762c2120cbc0000ee8c697c73ea692 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -234,6 +234,12 @@ mt7530_write(struct mt7530_priv *priv, u
+@@ -235,6 +235,12 @@ mt7530_write(struct mt7530_priv *priv, u
  }
  
  static u32
@@ -41,7 +41,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  _mt7530_read(struct mt7530_dummy_poll *p)
  {
        struct mii_bus          *bus = p->priv->bus;
-@@ -481,6 +487,108 @@ mt7530_pad_clk_setup(struct dsa_switch *
+@@ -482,6 +488,108 @@ mt7530_pad_clk_setup(struct dsa_switch *
        return 0;
  }
  
@@ -150,7 +150,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  static void
  mt7530_mib_reset(struct dsa_switch *ds)
  {
-@@ -505,6 +613,217 @@ static int mt7530_phy_write(struct dsa_s
+@@ -506,6 +614,217 @@ static int mt7530_phy_write(struct dsa_s
        return mdiobus_write_nested(priv->bus, port, regnum, val);
  }
  
@@ -368,7 +368,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  static void
  mt7530_get_strings(struct dsa_switch *ds, int port, u32 stringset,
                   uint8_t *data)
-@@ -621,9 +940,14 @@ unlock_exit:
+@@ -622,9 +941,14 @@ unlock_exit:
  }
  
  static int
@@ -385,7 +385,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
        /* Enable Mediatek header mode on the cpu port */
        mt7530_write(priv, MT7530_PVC_P(port),
                     PORT_SPEC_TAG);
-@@ -636,7 +960,7 @@ mt7530_cpu_port_enable(struct mt7530_pri
+@@ -637,7 +961,7 @@ mt7530_cpu_port_enable(struct mt7530_pri
                mt7530_rmw(priv, MT7530_MFC, CPU_MASK, CPU_EN | CPU_PORT(port));
  
        /* CPU port gets connected to all user ports of
@@ -394,7 +394,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
         */
        mt7530_write(priv, MT7530_PCR_P(port),
                     PCR_MATRIX(dsa_user_ports(priv->ds)));
-@@ -1122,27 +1446,42 @@ mt7530_port_vlan_del(struct dsa_switch *
+@@ -1123,27 +1447,42 @@ mt7530_port_vlan_del(struct dsa_switch *
        return 0;
  }
  
@@ -444,7 +444,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  
        val = mt7530_read(priv, MT7530_PCR_P(port));
        if (ingress) {
-@@ -1157,7 +1496,7 @@ static int mt7530_port_mirror_add(struct
+@@ -1158,7 +1497,7 @@ static int mt7530_port_mirror_add(struct
        return 0;
  }
  
@@ -453,7 +453,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                                   struct dsa_mall_mirror_tc_entry *mirror)
  {
        struct mt7530_priv *priv = ds->priv;
-@@ -1174,9 +1513,9 @@ static void mt7530_port_mirror_del(struc
+@@ -1175,9 +1514,9 @@ static void mt7530_port_mirror_del(struc
        mt7530_write(priv, MT7530_PCR_P(port), val);
  
        if (!priv->mirror_rx && !priv->mirror_tx) {
@@ -466,7 +466,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
        }
  }
  
-@@ -1282,7 +1621,7 @@ mt7530_setup(struct dsa_switch *ds)
+@@ -1283,7 +1622,7 @@ mt7530_setup(struct dsa_switch *ds)
                           PCR_MATRIX_CLR);
  
                if (dsa_is_cpu_port(ds, i))
@@ -475,7 +475,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                else
                        mt7530_port_disable(ds, i);
  
-@@ -1336,6 +1675,118 @@ mt7530_setup(struct dsa_switch *ds)
+@@ -1337,6 +1676,118 @@ mt7530_setup(struct dsa_switch *ds)
        return 0;
  }
  
@@ -594,7 +594,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  static bool
  mt7530_phy_mode_supported(struct dsa_switch *ds, int port,
                          const struct phylink_link_state *state)
-@@ -1374,6 +1825,47 @@ unsupported:
+@@ -1375,6 +1826,47 @@ unsupported:
        return false;
  }
  
@@ -642,7 +642,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  static bool
  mt753x_phy_mode_supported(struct dsa_switch *ds, int port,
                          const struct phylink_link_state *state)
-@@ -1406,6 +1898,227 @@ mt7530_mac_config(struct dsa_switch *ds,
+@@ -1407,6 +1899,227 @@ mt7530_mac_config(struct dsa_switch *ds,
        return 0;
  }
  
@@ -870,7 +870,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  static int
  mt753x_mac_config(struct dsa_switch *ds, int port, unsigned int mode,
                  const struct phylink_link_state *state)
-@@ -1441,6 +2154,8 @@ mt753x_phylink_mac_config(struct dsa_swi
+@@ -1442,6 +2155,8 @@ mt753x_phylink_mac_config(struct dsa_swi
                if (mt753x_mac_config(ds, port, mode, state) < 0)
                        goto unsupported;
  
@@ -879,7 +879,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                break;
        case 6: /* 1st cpu port */
                if (priv->p6_interface == state->interface)
-@@ -1460,7 +2175,8 @@ unsupported:
+@@ -1461,7 +2176,8 @@ unsupported:
                return;
        }
  
@@ -889,7 +889,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                dev_err(ds->dev, "%s: in-band negotiation unsupported\n",
                        __func__);
                return;
-@@ -1470,7 +2186,7 @@ unsupported:
+@@ -1471,7 +2187,7 @@ unsupported:
        mcr_new = mcr_cur;
        mcr_new &= ~PMCR_LINK_SETTINGS_MASK;
        mcr_new |= PMCR_IFG_XMIT(1) | PMCR_MAC_MODE | PMCR_BACKOFF_EN |
@@ -898,7 +898,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  
        /* Are we connected to external phy */
        if (port == 5 && dsa_is_user_port(ds, 5))
-@@ -1480,7 +2196,18 @@ unsupported:
+@@ -1481,7 +2197,18 @@ unsupported:
                mt7530_write(priv, MT7530_PMCR_P(port), mcr_new);
  }
  
@@ -918,7 +918,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                                         unsigned int mode,
                                         phy_interface_t interface)
  {
-@@ -1489,7 +2216,19 @@ static void mt7530_phylink_mac_link_down
+@@ -1490,7 +2217,19 @@ static void mt7530_phylink_mac_link_down
        mt7530_clear(priv, MT7530_PMCR_P(port), PMCR_LINK_SETTINGS_MASK);
  }
  
@@ -939,7 +939,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                                       unsigned int mode,
                                       phy_interface_t interface,
                                       struct phy_device *phydev,
-@@ -1499,18 +2238,29 @@ static void mt7530_phylink_mac_link_up(s
+@@ -1500,18 +2239,29 @@ static void mt7530_phylink_mac_link_up(s
        struct mt7530_priv *priv = ds->priv;
        u32 mcr;
  
@@ -971,7 +971,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                break;
        }
        if (duplex == DUPLEX_FULL) {
-@@ -1524,6 +2274,45 @@ static void mt7530_phylink_mac_link_up(s
+@@ -1525,6 +2275,45 @@ static void mt7530_phylink_mac_link_up(s
        mt7530_set(priv, MT7530_PMCR_P(port), mcr);
  }
  
@@ -1017,7 +1017,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  static void
  mt7530_mac_port_validate(struct dsa_switch *ds, int port,
                         unsigned long *supported)
-@@ -1532,6 +2321,14 @@ mt7530_mac_port_validate(struct dsa_swit
+@@ -1533,6 +2322,14 @@ mt7530_mac_port_validate(struct dsa_swit
                phylink_set(supported, 1000baseX_Full);
  }
  
@@ -1032,7 +1032,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  static void
  mt753x_phylink_validate(struct dsa_switch *ds, int port,
                        unsigned long *supported,
-@@ -1548,7 +2345,8 @@ mt753x_phylink_validate(struct dsa_switc
+@@ -1549,7 +2346,8 @@ mt753x_phylink_validate(struct dsa_switc
  
        phylink_set_port_modes(mask);
  
@@ -1042,7 +1042,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
                phylink_set(mask, 10baseT_Half);
                phylink_set(mask, 10baseT_Full);
                phylink_set(mask, 100baseT_Half);
-@@ -1567,6 +2365,11 @@ mt753x_phylink_validate(struct dsa_switc
+@@ -1568,6 +2366,11 @@ mt753x_phylink_validate(struct dsa_switc
  
        linkmode_and(supported, supported, mask);
        linkmode_and(state->advertising, state->advertising, mask);
@@ -1054,7 +1054,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  }
  
  static int
-@@ -1657,6 +2460,63 @@ static int mt7530_set_mac_eee(struct dsa
+@@ -1658,6 +2461,63 @@ static int mt7530_set_mac_eee(struct dsa
        return 0;
  }
  
@@ -1118,7 +1118,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
  static int
  mt753x_phylink_mac_link_state(struct dsa_switch *ds, int port,
                              struct phylink_link_state *state)
-@@ -1710,13 +2570,14 @@ static const struct dsa_switch_ops mt753
+@@ -1711,13 +2571,14 @@ static const struct dsa_switch_ops mt753
        .port_vlan_prepare      = mt7530_port_vlan_prepare,
        .port_vlan_add          = mt7530_port_vlan_add,
        .port_vlan_del          = mt7530_port_vlan_del,
@@ -1137,7 +1137,7 @@ Signed-off-by: Sean Wang <sean.wang@mediatek.com>
        .get_mac_eee            = mt7530_get_mac_eee,
        .set_mac_eee            = mt7530_set_mac_eee,
  };
-@@ -1744,11 +2605,26 @@ static const struct mt753x_info mt753x_t
+@@ -1745,11 +2606,26 @@ static const struct mt753x_info mt753x_t
                .mac_port_get_state = mt7530_phylink_mac_link_state,
                .mac_port_config = mt7530_mac_config,
        },
index 1be9a6022942c218be0ef6ed464da425c7292a83..f62617f992649bfd043de21875c6b7321c76f8fd 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
 
 --- a/drivers/platform/x86/pcengines-apuv2.c
 +++ b/drivers/platform/x86/pcengines-apuv2.c
-@@ -186,6 +186,33 @@ static const struct dmi_system_id apu_gp
+@@ -188,6 +188,33 @@ static const struct dmi_system_id apu_gp
                },
                .driver_data = (void *)&board_apu2,
        },