kernel: bump 5.10 to 5.10.53
authorRui Salvaterra <rsalvaterra@gmail.com>
Sun, 25 Jul 2021 20:00:58 +0000 (21:00 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 29 Jul 2021 18:50:15 +0000 (19:50 +0100)
No deleted or manually refreshed patches.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
include/kernel-version.mk
target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
target/linux/generic/pending-5.10/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
target/linux/generic/pending-5.10/201-extra_optimization.patch
target/linux/generic/pending-5.10/768-net-dsa-mv88e6xxx-Request-assisted-learning-on-CPU-port.patch
target/linux/ramips/patches-5.10/700-net-ethernet-mediatek-support-net-labels.patch

index 0ab7ce31cedf2ad87b7861f9e5d9100ef099420f..c2fb813c927cf5bc0efc5d0cd0d4dd112ca5246a 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .134
-LINUX_VERSION-5.10 = .52
+LINUX_VERSION-5.10 = .53
 
 LINUX_KERNEL_HASH-5.4.134 = c9fb861642161c256e10c97c35ccce18831e688d87ead53c18e3226778e05841
-LINUX_KERNEL_HASH-5.10.52 = 769e57a0fa218589fa2f8460b8682eb784a72718c7a3d95295f382a77902ae79
+LINUX_KERNEL_HASH-5.10.53 = f0058d902933986dbaf03b2a0304d2babe5fe1c8e3f41f156ffd3c3f210106dc
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index c77de17db018084a70ce9bb21e2e5d887a753bef..e0bcb8d34ef78968ed26c3c6a6e33e8b6a9232de 100644 (file)
  #include <linux/uaccess.h>
  #include <linux/ipv6.h>
  #include <linux/icmpv6.h>
-@@ -909,10 +910,10 @@ static void tcp_v6_send_response(const s
+@@ -924,10 +925,10 @@ static void tcp_v6_send_response(const s
        topt = (__be32 *)(t1 + 1);
  
        if (tsecr) {
index 4375e727cf60c46180650520ac922b1f15481788..cf3bbd1f0f8ccdc0d3a4612e8cab0a528e634aa1 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -7027,7 +7027,7 @@ static void __ref alloc_node_mem_map(str
+@@ -7053,7 +7053,7 @@ static void __ref alloc_node_mem_map(str
        if (pgdat == NODE_DATA(0)) {
                mem_map = NODE_DATA(0)->node_mem_map;
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
index df973258ab6d294681b26a2ce73491196aa18e8f..cb1de80764109a832cc4561dd26838005f5e1920 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -734,11 +734,11 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
+@@ -735,11 +735,11 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
  KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE
index 315a1a0bdbec4e277d41a4b13eb4dec0182e2e12..add1be7bd04d1a11f4919bf491290e3d4e683247 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Tobias Waldekranz <tobias@waldekranz.com>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -5401,6 +5401,7 @@ static int mv88e6xxx_register_switch(str
+@@ -5409,6 +5409,7 @@ static int mv88e6xxx_register_switch(str
        ds->ops = &mv88e6xxx_switch_ops;
        ds->ageing_time_min = chip->info->age_time_coeff;
        ds->ageing_time_max = chip->info->age_time_coeff * U8_MAX;
index c32c16a90876f57864fb74cfdf62a62ee4f21f39..8f4a2d98481ab823a909e7ff45e31a27435066b8 100644 (file)
@@ -22,9 +22,9 @@ Signed-off-by: RenĂ© van Dorst <opensource@vdorst.com>
        const __be32 *_id = of_get_property(np, "reg", NULL);
        phy_interface_t phy_mode;
        struct phylink *phylink;
-@@ -3006,6 +3007,9 @@ static int mtk_add_mac(struct mtk_eth *e
-       eth->netdev[id]->max_mtu = MTK_MAX_RX_LENGTH - MTK_RX_ETH_HLEN;
+@@ -3008,6 +3009,9 @@ static int mtk_add_mac(struct mtk_eth *e
+       
+       of_platform_device_create(np, NULL, NULL);
  
 +      if (name)
 +              strlcpy(eth->netdev[id]->name, name, IFNAMSIZ);