kernel: bump 4.14 to 4.14.232
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 10 May 2021 12:25:40 +0000 (14:25 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 10 May 2021 12:51:57 +0000 (14:51 +0200)
Refreshed all patches.

Fixes:
- CVE-2021-23133

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/pending-4.14/600-netfilter_conntrack_flush.patch
target/linux/samsung/patches-4.14/002-dm9000-clk.patch

index b9f53a7366f4658a9df09a04791be0b3820cc62c..514d1973617c2712acd0bfaa2d3cfd2140632c36 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .231
+LINUX_VERSION-4.14 = .232
 
-LINUX_KERNEL_HASH-4.14.231 = 573b79adee3490a8dd82f663bb187218288c99cd2613fd9f69edf915f91e6682
+LINUX_KERNEL_HASH-4.14.232 = 1dc19361f6970bc94cc62be066702483db9cbd3d63f3089a8c90dabfced74369
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 39ef23be2ac34703a78b8fac637470ee3b1b6305..1a4321cb960075ca67240946f631fff2f4410692 100644 (file)
@@ -140,7 +140,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  #endif
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -309,10 +309,12 @@ static int ct_seq_show(struct seq_file *
+@@ -310,10 +310,12 @@ static int ct_seq_show(struct seq_file *
        WARN_ON(!l4proto);
  
        ret = -ENOSPC;
@@ -156,7 +156,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  
        if (l4proto->print_conntrack)
                l4proto->print_conntrack(s, ct);
-@@ -339,7 +341,9 @@ static int ct_seq_show(struct seq_file *
+@@ -340,7 +342,9 @@ static int ct_seq_show(struct seq_file *
        if (seq_print_acct(s, ct, IP_CT_DIR_REPLY))
                goto release;
  
index 10da96b7ed4000aef0f113a10c771e7bdc21957e..14a23a9fea18001a04b28d40cb11384bc5956388 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #include <net/net_namespace.h>
  #ifdef CONFIG_SYSCTL
  #include <linux/sysctl.h>
-@@ -381,10 +382,66 @@ static int ct_open(struct inode *inode,
+@@ -382,10 +383,66 @@ static int ct_open(struct inode *inode,
                        sizeof(struct ct_iter_state));
  }
  
@@ -84,7 +84,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        .llseek  = seq_lseek,
        .release = seq_release_net,
  };
-@@ -488,7 +545,7 @@ static int nf_conntrack_standalone_init_
+@@ -489,7 +546,7 @@ static int nf_conntrack_standalone_init_
        kuid_t root_uid;
        kgid_t root_gid;
  
index cbde5edc02683ee73486fa8448109e8b4af0d9f0..0dd58fdf62277759d758a7cb59987bcef2cd9977 100644 (file)
@@ -16,7 +16,7 @@
  
        power = devm_regulator_get(dev, "vcc");
        if (IS_ERR(power)) {
-@@ -1579,6 +1581,18 @@ dm9000_probe(struct platform_device *pde
+@@ -1581,6 +1583,18 @@ dm9000_probe(struct platform_device *pde
                goto out;
        }