Generate a flashable image for the NSLU2
authorRod Whitby <rod@whitby.id.au>
Sat, 23 Dec 2006 08:10:35 +0000 (08:10 +0000)
committerRod Whitby <rod@whitby.id.au>
Sat, 23 Dec 2006 08:10:35 +0000 (08:10 +0000)
SVN-Revision: 5893

target/linux/ixp4xx-2.6/image/Makefile

index 79979ec78cb075de12a3288b159101e98790ef07..6142d09faf3dffe4e1829939da10c8590afc5e72 100644 (file)
@@ -29,6 +29,12 @@ endef
 
 define Image/Build/jffs2-128k
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+               -r Ramdisk:1,Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+#              -L $(BIN_DIR)/apex-nslu2-armeb.bin
+#              -m $(BIN_DIR)/NPE-B
 endef
 
 $(eval $(call BuildImage))