include: image.mk: use correct flag for fixed mtimes with make_ext4fs (#21768)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 1 Feb 2016 13:58:43 +0000 (13:58 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 1 Feb 2016 13:58:43 +0000 (13:58 +0000)
The correct flag for fixed mtime is -T, not -t.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 48610

include/image.mk

index 2d6550841d82e9b3b4d7e1c783e3475a98d8c433..68686176dfedbaf2b5946fe42a948672f6837eb0 100644 (file)
@@ -263,7 +263,7 @@ define Image/mkfs/ext4
                -i $(CONFIG_TARGET_EXT4_MAXINODE) \
                -m $(CONFIG_TARGET_EXT4_RESERVED_PCT) \
                $(if $(CONFIG_TARGET_EXT4_JOURNAL),,-J) \
                -i $(CONFIG_TARGET_EXT4_MAXINODE) \
                -m $(CONFIG_TARGET_EXT4_RESERVED_PCT) \
                $(if $(CONFIG_TARGET_EXT4_JOURNAL),,-J) \
-               $(if $(SOURCE_DATE_EPOCH),-t $(SOURCE_DATE_EPOCH)) \
+               $(if $(SOURCE_DATE_EPOCH),-T $(SOURCE_DATE_EPOCH)) \
                $(KDIR)/root.ext4 $(TARGET_DIR)/
 endef
 
                $(KDIR)/root.ext4 $(TARGET_DIR)/
 endef