kernel: Fix xen domU kmod-xen-kbd package
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:45:05 +0000 (12:45 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:45:05 +0000 (12:45 +0000)
modified version of http://patchwork.openwrt.org/patch/5526/

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 40941

package/kernel/linux/modules/virtual.mk

index e1bbe3f439b22167470f6441c1ba495d78d76cfa..3a1fe006fa099ffce44e487b1b4cfa9000b92dd0 100644 (file)
@@ -142,8 +142,9 @@ $(eval $(call KernelPackage,xen-fbdev))
 define KernelPackage/xen-kbddev
   SUBMENU:=$(VIRTUAL_MENU)
   TITLE:=Xen virtual keyboard and mouse
-  DEPENDS:=@TARGET_x86_xen_domu
-  KCONFIG:=CONFIG_XEN_KBDDEV_FRONTEND
+  DEPENDS:=@TARGET_x86_xen_domu +kmod-input-core
+  KCONFIG:=CONFIG_INPUT_MISC=y \
+       CONFIG_INPUT_XEN_KBDDEV_FRONTEND
   FILES:=$(LINUX_DIR)/drivers/input/xen-kbdfront.ko
   AUTOLOAD:=$(call AutoLoad,08,xen-kbdfront)
 endef