OpenWrt v18.06: set branch defaults
authorJohn Crispin <john@phrozen.org>
Tue, 15 May 2018 13:14:27 +0000 (15:14 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 15 May 2018 13:14:27 +0000 (15:14 +0200)
Signed-off-by: John Crispin <john@phrozen.org>
feeds.conf.default
include/version.mk
package/base-files/image-config.in

index da6c6656244f4ae41a05ad91d7031e1fe78cc711..763a26902e5fedbcbbc68a866b384fcf176a1f1e 100644 (file)
@@ -1,9 +1,4 @@
-src-git packages https://git.openwrt.org/feed/packages.git
-src-git luci https://git.openwrt.org/project/luci.git
-src-git routing https://git.openwrt.org/feed/routing.git
-src-git telephony https://git.openwrt.org/feed/telephony.git
-#src-git video https://github.com/openwrt/video.git
-#src-git targets https://github.com/openwrt/targets.git
-#src-git management https://github.com/openwrt-management/packages.git
-#src-git oldpackages http://git.openwrt.org/packages.git
-#src-link custom /usr/src/openwrt/custom-feed
+src-git packages https://git.openwrt.org/feed/packages.git;openwrt-18.06
+src-git luci https://git.openwrt.org/project/luci.git;openwrt-18.06
+src-git routing https://git.openwrt.org/feed/routing.git;openwrt-18.06
+src-git telephony https://git.openwrt.org/feed/telephony.git;openwrt-18.06
index ab427ecba89746ce8ebf4de24d6d4f1e1cd21082..a1e5608eb7ae10c2b558f37ef1161c9653a1d36d 100644 (file)
@@ -25,13 +25,13 @@ PKG_CONFIG_DEPENDS += \
 sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
 
 VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),18.06-SNAPSHOT)
 
 VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_CODE))
 VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
 
 VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/releases/18.06-SNAPSHOT)
 
 VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
index dbbd60b1527cdb77d3ffd221b33ea09f5d60fb9e..5ee2d3e4e320d337a0fb0f46ae4649ae847cd6c2 100644 (file)
@@ -183,7 +183,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.lede-project.org/snapshots"
+               default "http://downloads.openwrt.org/releases/18.06-SNAPSHOT"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders: