libpcap: add -fpic, refresh patches
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 10:36:25 +0000 (10:36 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 10:36:25 +0000 (10:36 +0000)
SVN-Revision: 26999

package/libpcap/Makefile
package/libpcap/patches/102-makefile_disable_manpages.patch
package/libpcap/patches/201-space_optimization.patch
package/libpcap/patches/202-protocol_api.patch

index c2a3b74b1cff8e109a2c2310fdea50014f71b87c..75c3ddf3c65e27cd9ed1dd3e1d58116b50046335 100644 (file)
@@ -38,6 +38,7 @@ define Package/libpcap/config
 endef
 
 TARGET_CFLAGS += \
+       $(FPIC) \
        -ffunction-sections \
        -fdata-sections
 
index e9cde4f46adb4c59e331d934ec4ebf65b756d0e8..7756c99eada7b10a41209734bee3a0fb8c117d13 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -539,62 +539,12 @@ install: install-shared install-archive
+@@ -539,62 +539,12 @@ install: install-shared install-archive 
            (mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir))
        [ -d $(DESTDIR)$(includedir)/pcap ] || \
            (mkdir -p $(DESTDIR)$(includedir)/pcap; chmod 755 $(DESTDIR)$(includedir)/pcap)
index 29c293b623943ae1a1c0aea2a13894bb9045aa10..f3eec4c839af3dfe2c3ca5cf256f0e91c9b319fd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gencode.c
 +++ b/gencode.c
-@@ -439,20 +439,6 @@ pcap_compile_nopcap(int snaplen_arg, int
+@@ -491,20 +491,6 @@ pcap_compile_nopcap(int snaplen_arg, int
  }
  
  /*
@@ -23,7 +23,7 @@
   * back to another unresolved block (or nil).  At least one of the fields
 --- a/pcap.c
 +++ b/pcap.c
-@@ -698,6 +698,59 @@ static const u_char charmap[] = {
+@@ -748,6 +748,59 @@ static const u_char charmap[] = {
        (u_char)'\374', (u_char)'\375', (u_char)'\376', (u_char)'\377',
  };
  
@@ -85,7 +85,7 @@
  {
 --- a/optimize.c
 +++ b/optimize.c
-@@ -2278,45 +2278,6 @@ icode_to_fcode(root, lenp)
+@@ -2292,45 +2292,6 @@ icode_to_fcode(root, lenp)
        return fp;
  }
  
index 892aeb7e0de34227f2c03e733bb6106e5635864a..6d59b495d040c856e0e2899a5797efc6140b4865 100644 (file)
        return (p);
  }
  
-@@ -317,6 +319,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
-       return 0;
+@@ -318,6 +320,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
  }
  
-+int
+ int
 +pcap_set_protocol(pcap_t *p, unsigned short proto)
 +{
 +      if (pcap_check_activated(p))
 +      return 0;
 +}
 +
- int
++int
  pcap_activate(pcap_t *p)
  {
+       int status;
 --- a/pcap/pcap.h
 +++ b/pcap/pcap.h
 @@ -68,6 +68,7 @@ extern "C" {