CI: allow dots in commit subject area
authorPaul Spooren <mail@aparcar.org>
Wed, 23 Feb 2022 18:51:43 +0000 (19:51 +0100)
committerPaul Spooren <mail@aparcar.org>
Thu, 24 Feb 2022 15:41:02 +0000 (16:41 +0100)
Due to a limited grep pattern, subjects containing dots like `image.mk`
were falsely reported as problematic. Extend pattern to allow dots.

Signed-off-by: Paul Spooren <mail@aparcar.org>
.github/workflows/formal.yml

index 74e8fd6942e6b865d5aaebd057219d764ac77e04..5046b5a180cc84b717158c5e68401cd71f143d6e 100644 (file)
@@ -43,7 +43,7 @@ jobs:
             fi
 
             subject="$(git show -s --format=%s $commit)"
-            if echo "$subject" | grep -q -e '^[0-9A-Za-z,+/_-]\+: ' -e '^Revert '; then
+            if echo "$subject" | grep -q -e '^[0-9A-Za-z,+/_\.-]\+: ' -e '^Revert '; then
               success "Commit subject line seems ok ($subject)"
             else
               err "Commit subject line MUST start with '<area>: ' ($subject)"