build: use busybox gzip compatible force option
authorMathew McBride <matt@traverse.com.au>
Wed, 28 Mar 2018 02:34:52 +0000 (13:34 +1100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 21 May 2018 16:07:48 +0000 (18:07 +0200)
commit 138c763 ("build: add --force option to gzip in Build/gzip")
added the --force flag to the gzip invocation.

Under environments with busybox gzip (e.g Alpine Linux), this fails
as busybox only recognizes "-f".

Signed-off-by: Mathew McBride <matt@traverse.com.au>
include/image-commands.mk

index a8486553998e882ec46ce1434003fece3ce6118c..e0322080e96c0b115fbd2c861e18c180afe12155 100644 (file)
@@ -135,7 +135,7 @@ define Build/lzma-no-dict
 endef
 
 define Build/gzip
-       gzip --force -9n -c $@ $(1) > $@.new
+       gzip -f -9n -c $@ $(1) > $@.new
        @mv $@.new $@
 endef