tools/quilt: fix spurious calls to the configure and Makefile targets (#8462)
authorFelix Fietkau <nbd@openwrt.org>
Mon, 1 Aug 2011 19:22:45 +0000 (19:22 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 1 Aug 2011 19:22:45 +0000 (19:22 +0000)
SVN-Revision: 27869

tools/quilt/patches/000-fix_compile.patch [new file with mode: 0644]

diff --git a/tools/quilt/patches/000-fix_compile.patch b/tools/quilt/patches/000-fix_compile.patch
new file mode 100644 (file)
index 0000000..51a4f5e
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -273,13 +273,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+ lib/backup-files.o :: Makefile
+ configure : configure.ac aclocal.m4
+-      autoconf
+-      @echo "Please run ./configure"
+-      @false
++      @touch $@
+ Makefile : Makefile.in configure
+-      @echo "Please run ./configure"
+-      @false
++      @touch $@
+ compat_leftover := $(filter-out $(COMPAT),$(shell $(FIND) compat -maxdepth 1 -type f -perm +111))