kernel: bump 5.10 to 5.10.138
authorJohn Audia <therealgraysky@proton.me>
Thu, 25 Aug 2022 14:52:50 +0000 (10:52 -0400)
committerPetr Štetiar <ynezz@true.cz>
Thu, 25 Aug 2022 18:23:59 +0000 (20:23 +0200)
All patches automatically rebased.

Signed-off-by: John Audia <therealgraysky@proton.me>
include/kernel-5.10
target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch
target/linux/generic/hack-5.10/321-powerpc_crtsavres_prereq.patch
target/linux/octeon/patches-5.10/130-itus_shield_support.patch
target/linux/octeon/patches-5.10/150-ubnt_usg_support.patch
target/linux/octeontx/patches-5.10/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch

index 762e4674686ccfcc92840d8b5bfd60168d93e770..4143799e89705abcccb4677ebc5fbad9a3b25494 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .137
-LINUX_KERNEL_HASH-5.10.137 = c16bcd4d1453d7e645007d0a25270f52401331c7df81c364f57bde914e1616c8
+LINUX_VERSION-5.10 = .138
+LINUX_KERNEL_HASH-5.10.138 = 29a003bb8e0e3a45942f703370fb0b3460e6fdcbbad37424423c9cf831ab5ba8
index 5ab2718ecbf54edeb683a8deda048c4a29ddf98f..eea0aed6aae45d474fcbac83f20f230b3210767d 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        struct nft_set                  *set;
 --- a/net/netfilter/nf_tables_api.c
 +++ b/net/netfilter/nf_tables_api.c
-@@ -893,6 +893,12 @@ static void nf_tables_table_disable(stru
+@@ -917,6 +917,12 @@ static void nf_tables_table_disable(stru
        nft_table_disable(net, table, 0);
  }
  
@@ -47,7 +47,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static int nf_tables_updtable(struct nft_ctx *ctx)
  {
        struct nft_trans *trans;
-@@ -916,19 +922,17 @@ static int nf_tables_updtable(struct nft
+@@ -940,19 +946,17 @@ static int nf_tables_updtable(struct nft
  
        if ((flags & NFT_TABLE_F_DORMANT) &&
            !(ctx->table->flags & NFT_TABLE_F_DORMANT)) {
@@ -70,7 +70,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        nft_trans_table_update(trans) = true;
        list_add_tail(&trans->list, &ctx->net->nft.commit_list);
        return 0;
-@@ -7931,11 +7935,10 @@ static int nf_tables_commit(struct net *
+@@ -7929,11 +7933,10 @@ static int nf_tables_commit(struct net *
                switch (trans->msg_type) {
                case NFT_MSG_NEWTABLE:
                        if (nft_trans_table_update(trans)) {
@@ -86,7 +86,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                        } else {
                                nft_clear(net, trans->ctx.table);
                        }
-@@ -8148,11 +8151,9 @@ static int __nf_tables_abort(struct net
+@@ -8147,11 +8150,9 @@ static int __nf_tables_abort(struct net
                switch (trans->msg_type) {
                case NFT_MSG_NEWTABLE:
                        if (nft_trans_table_update(trans)) {
index 4bb438295de234893b2392ec19649f7a5130c1f7..c4fd475b1f57d537d73017b3bd36edafe40aa787 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
 
 --- a/arch/powerpc/Makefile
 +++ b/arch/powerpc/Makefile
-@@ -61,19 +61,6 @@ machine-$(CONFIG_PPC64) += 64
+@@ -44,19 +44,6 @@ machine-$(CONFIG_PPC64) += 64
  machine-$(CONFIG_CPU_LITTLE_ENDIAN) += le
  UTS_MACHINE := $(subst $(space),,$(machine-y))
  
index 15f514209dcd128aa2e4a2f136395ee62e672b76..a041331c20dd627230876ffb9a9bb1e4839c27a1 100644 (file)
@@ -20,7 +20,7 @@
        }
 --- a/arch/mips/cavium-octeon/octeon-platform.c
 +++ b/arch/mips/cavium-octeon/octeon-platform.c
-@@ -773,7 +773,7 @@ int __init octeon_prune_device_tree(void
+@@ -774,7 +774,7 @@ int __init octeon_prune_device_tree(void
        if (fdt_check_header(initial_boot_params))
                panic("Corrupt Device Tree.");
  
index 721f6579781d2f607b542435753006f209010aef..88aa1c406f9b0b796cd9700d90d610db1aee2dd6 100644 (file)
@@ -18,7 +18,7 @@
                ENUM_BRD_TYPE_CASE(CVMX_BOARD_TYPE_ITUS_SHIELD)
 --- a/arch/mips/cavium-octeon/octeon-platform.c
 +++ b/arch/mips/cavium-octeon/octeon-platform.c
-@@ -634,6 +634,7 @@ static void __init octeon_rx_tx_delay(in
+@@ -635,6 +635,7 @@ static void __init octeon_rx_tx_delay(in
                }
                break;
        case CVMX_BOARD_TYPE_UBNT_E100:
index 76e97ccbeb1c72a8e8115b4bd0681665eb9239f4..28502d393fb391c2a1e1a35684c0fd6c567baa60 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
  #include <linux/platform_data/x86/apple.h>
  #include <linux/pm_runtime.h>
  #include <linux/suspend.h>
-@@ -5784,3 +5785,34 @@ static void nvidia_ion_ahci_fixup(struct
+@@ -5787,3 +5788,34 @@ static void nvidia_ion_ahci_fixup(struct
        pdev->dev_flags |= PCI_DEV_FLAGS_HAS_MSI_MASKING;
  }
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_NVIDIA, 0x0ab8, nvidia_ion_ahci_fixup);