image-commands.mk: Be consistent in command invocation
authorOlliver Schinagl <oliver@schinagl.nl>
Wed, 14 Dec 2022 10:39:17 +0000 (11:39 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 21 Dec 2022 23:14:30 +0000 (00:14 +0100)
Most/all other tools use the staging dir prefix, gzip should as well.

Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Acked-by: Christian Marangi <ansuelsmth@gmail.com>
(cherry picked from commit 47df168dd279d52127f6bbc623e79bdeeb6c8fd4)

include/image-commands.mk

index 402e3d71edb8d99e8eafdf97d0d730c5c69bc365..b4e1a67342c9805d5352a30c17ff85492f6654ce 100644 (file)
@@ -298,7 +298,7 @@ define Build/fit
 endef
 
 define Build/gzip
-       gzip -f -9n -c $@ $(1) > $@.new
+       $(STAGING_DIR_HOST)/bin/gzip -f -9n -c $@ $(1) > $@.new
        @mv $@.new $@
 endef