kernel: fix segmentation fault in mconf on linux
authorFelix Fietkau <nbd@nbd.name>
Wed, 7 Jun 2017 16:14:27 +0000 (18:14 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 7 Jun 2017 16:31:10 +0000 (18:31 +0200)
Commit 86c966a8ae9c4e74b912a16a760aaed17c68eb32 caused HOST_LOADLIBES to
include -lncurses. This was added for fixing build issues on macOS.
This introduces issues on Linux when wide-character ncurses is being
used for compiling, but the non-wide-character version is linked in.

Fix this by adding the extra override for HOST_LOADLIBES only on macOS.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/kernel-build.mk

index e98d801939aaa7f741638b4ea50bb0e77e8303a9..e45b43f00a09337b90394bb26955c95be2a54b82 100644 (file)
@@ -159,7 +159,9 @@ define BuildKernel
        rm -f $(LINUX_DIR)/.config.prev
        rm -f $(STAMP_CONFIGURED)
        $(LINUX_RECONF_CMD) > $(LINUX_DIR)/.config
-       $(_SINGLE)$(KERNEL_MAKE) HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses" $$@
+       $(_SINGLE)$(KERNEL_MAKE) \
+               $(if $(findstring Darwin,$(HOST_OS)),HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses") \
+               $$@
        $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config > $(LINUX_RECONFIG_TARGET)
 
   install: $(LINUX_DIR)/.image