build: log time taken by each packages/steps
authorEtienne Champetier <champetier.etienne@gmail.com>
Mon, 30 Apr 2018 19:55:12 +0000 (12:55 -0700)
committerJohn Crispin <john@phrozen.org>
Mon, 7 May 2018 08:31:35 +0000 (10:31 +0200)
The idea is to easily get the list of packages taking the most time to build,
and see if we can improve them

v1: Use SetupHostCommand as recommended by John
v2: add space after 'time:', remove useless /usr/bin/time from SetupHostCommand

Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
include/prereq-build.mk
include/subdir.mk

index 5b9a7e049d15720fa51815706a067278fa27b1b3..bac5fdc84c651d29a66a52883c4ecd6caf90bb1d 100644 (file)
@@ -138,6 +138,10 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
 $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
+$(eval $(call SetupHostCommand,gtime,Please install GNU 'time', \
+       gtime --version 2>&1 | grep GNU, \
+       time --version 2>&1 | grep GNU))
+
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
index 79a80528aef31528b696d133fa817b6970b4dd9b..ed4f7537d5c746b00b586a49ff89004895eaec21 100644 (file)
@@ -43,6 +43,7 @@ log_make = \
         $(if $(BUILD_LOG), \
                set -o pipefail; \
                mkdir -p $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4));) \
+       gtime -f "time: $(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2)\#%U\#%S\#%e" -- \
        $$(SUBMAKE) $(subdir_make_opts) $(if $(3),$(3)-)$(2) \
                $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2).txt)