build: prevent spurious package rebuilds under CONFIG_AUTOREMOVE
authorJo-Philipp Wich <jo@mein.io>
Tue, 22 May 2018 07:18:33 +0000 (09:18 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 22 May 2018 07:28:16 +0000 (09:28 +0200)
When CONFIG_AUTOREMOVE is enabled, the build system touches an additional
".autoremove" stamp file in the cleaned build directory.

Since the autoremove stamp file is touched after the compile process
completed, it ends up being the most recent file of the package build
directory, causing the timestamp.pl check of depends.mk to erroneously
declare the ".built" and ".prepared" stamp files as stale, triggering
a forced clean-build submake process.

Fix the problem by using the ".built" stamp file as modification time
reference when touching the ".autoremove" stamp file.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit b287c82bed6673648a69be6c1cf84abe8885a3c4)

include/package.mk

index 9912c86d6b34207e0698feacf49e4a995dd32f76..2473eecb922074e415496e1add86cf2c9c47cccb 100644 (file)
@@ -228,7 +228,7 @@ define Build/CoreTargets
 
   ifneq ($(CONFIG_AUTOREMOVE),)
     compile:
-               -touch $(PKG_BUILD_DIR)/.autoremove 2>/dev/null >/dev/null
+               -touch -r $(PKG_BUILD_DIR)/.built $(PKG_BUILD_DIR)/.autoremove 2>/dev/null >/dev/null
                $(FIND) $(PKG_BUILD_DIR) -mindepth 1 -maxdepth 1 -not '(' -type f -and -name '.*' -and -size 0 ')' -and -not -name '.pkgdir' | \
                        $(XARGS) rm -rf
   endif